summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2014-05-29 15:06:22 +0200
committerRené 'Necoro' Neumann <necoro@necoro.net>2014-05-29 15:06:22 +0200
commit34fb352f8dea59023d5991a21e71a28ff54e63df (patch)
tree607331d92f8d17a0d845a0614e9e1c4806f2c56e
parentb05aa8c2485a3b1382af43f2ef89fa2e8c70f067 (diff)
downloadoverlay-34fb352f8dea59023d5991a21e71a28ff54e63df.tar.gz
overlay-34fb352f8dea59023d5991a21e71a28ff54e63df.tar.bz2
overlay-34fb352f8dea59023d5991a21e71a28ff54e63df.zip
Bump pass
-rw-r--r--app-admin/pass/Manifest1
-rw-r--r--app-admin/pass/pass-1.6.2.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/app-admin/pass/Manifest b/app-admin/pass/Manifest
index 9df57d0..26fb73e 100644
--- a/app-admin/pass/Manifest
+++ b/app-admin/pass/Manifest
@@ -1 +1,2 @@
DIST password-store-1.6.1.tar.xz 51096 SHA256 3c154d556c53c76b1a0ccacdc108c34f1fdb4a36fab28a6d2f42f02184290881 SHA512 11ceb1c7c0ab1b691c6d77f4f2402a4e10c68dd1057fadda6b70f1c56f68582edab820a581fb25fc3b8514ee9a2be7cd5438fa594189de705b10239b09df5cb3 WHIRLPOOL 705b173054bfa67d77474e522595a27e279e2c7c2d6f138d150934ae558cdc2a1f95d4420f3aa45e0148bd6443d6e207a526d44f627e9053bb1cf662ed7042f2
+DIST password-store-1.6.2.tar.xz 52684 SHA256 526c4a362f6b21ffbaa48fe9eed92f7c0af0be210f56160938fb1661a6f162b4 SHA512 b9d3a171420cee9596c028408f9aa812e6e764777c95d501f72743e52738c2600bbd2048e74835ce06a3bd7b199980c2d9173bfab3db5f06a5d6efb77224c7ab WHIRLPOOL fa17f52f18c64fd7c9d5d2f49f3403d2e2b158f5f71aa357dce8ce2aa3ccbb5d040b4d9c8e4901ffb257b3435db7bff8e76c8929648ccdf3e45f5a35f867835b
diff --git a/app-admin/pass/pass-1.6.2.ebuild b/app-admin/pass/pass-1.6.2.ebuild
new file mode 100644
index 0000000..10f65b0
--- /dev/null
+++ b/app-admin/pass/pass-1.6.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/pass/pass-1.6.2.ebuild,v 1.1 2014/05/14 07:49:03 zx2c4 Exp $
+
+EAPI=4
+
+inherit bash-completion-r1 elisp-common
+
+DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely using gpg, pwgen, and git"
+HOMEPAGE="http://zx2c4.com/projects/password-store/"
+SRC_URI="http://git.zx2c4.com/password-store/snapshot/password-store-${PV}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+IUSE="+git X zsh-completion fish-completion emacs dmenu importers elibc_Darwin"
+
+RDEPEND="
+ app-crypt/gnupg
+ app-admin/pwgen
+ >=app-text/tree-1.7.0
+ git? ( dev-vcs/git )
+ X? ( x11-misc/xclip )
+ elibc_Darwin? ( app-misc/getopt )
+ zsh-completion? ( app-shells/zsh-completion )
+ fish-completion? ( app-shells/fish )
+ dmenu? ( x11-misc/dmenu )
+ emacs? ( virtual/emacs )
+"
+
+S="${WORKDIR}/password-store-${PV}"
+
+src_prepare() {
+ sed -i -e 's/==/=/g' Makefile || die
+ use elibc_Darwin || return
+ # use coreutils'
+ sed -i -e 's/openssl base64/base64/g' src/platform/darwin.sh || die
+ # host getopt isn't cool, and we aren't brew (rip out brew reference)
+ sed -i -e '/^GETOPT=/s/=.*$/=getopt-long/' src/platform/darwin.sh || die
+ # make sure we can find "mount"
+ sed -i -e 's:mount -t:/sbin/mount -t:' src/platform/darwin.sh || die
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ use zsh-completion && export FORCE_ZSHCOMP=1
+ use fish-completion && export FORCE_FISHCOMP=1
+ default
+ use dmenu && dobin contrib/dmenu/passmenu
+ newbashcomp src/completion/pass.bash-completion pass
+ if use emacs; then
+ elisp-install ${PN} contrib/emacs/*.el
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
+ fi
+ if use importers; then
+ exeinto /usr/share/${PN}/importers
+ doexe contrib/importers/*
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ if use importers; then
+ einfo "To import passwords from other password managers, you may use the"
+ einfo "various importer scripts found in:"
+ einfo " ${ROOT}usr/share/${PN}/importers/"
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}