summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2015-04-28 14:12:40 +0200
committerRené 'Necoro' Neumann <necoro@necoro.net>2015-04-28 14:12:40 +0200
commit5a231c20f9b2951a9ef3412c7f79d560c15f0960 (patch)
tree40345c3e7191cffb35bc2a300c9556b487c54ba6
parent21672e9c22a2497c21a0aab285008ad27afc2566 (diff)
downloadoverlay-5a231c20f9b2951a9ef3412c7f79d560c15f0960.tar.gz
overlay-5a231c20f9b2951a9ef3412c7f79d560c15f0960.tar.bz2
overlay-5a231c20f9b2951a9ef3412c7f79d560c15f0960.zip
xdotool-9999
-rw-r--r--x11-misc/xdotool/xdotool-9999.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/x11-misc/xdotool/xdotool-9999.ebuild b/x11-misc/xdotool/xdotool-9999.ebuild
new file mode 100644
index 0000000..8c58e18
--- /dev/null
+++ b/x11-misc/xdotool/xdotool-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/xdotool-2.20110530.1.ebuild,v 1.10 2014/01/07 16:56:09 vapier Exp $
+
+EAPI=2
+
+EGIT_REPO_URI="https://github.com/jordansissel/xdotool.git"
+
+inherit eutils toolchain-funcs flag-o-matic multilib git-r3
+
+DESCRIPTION="Simulate keyboard input and mouse activity, move and resize windows"
+HOMEPAGE="http://www.semicomplete.com/projects/xdotool/"
+#SRC_URI="http://semicomplete.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="x11-libs/libXtst
+ x11-libs/libX11
+ x11-libs/libXinerama
+ x11-libs/libxkbcommon"
+DEPEND="${RDEPEND}"
+
+# The test wants to manualy start Xvfb, wont use VirtualX and it tries
+# to run a full gnome-session. For such a tiny application i consider
+# it overkill to rewrite the test scripts to not use it's own X server
+# and add a full blown gnome just to run the tests.
+RESTRICT="test"
+
+src_prepare() {
+ sed -i \
+ -e "s/installheader post-install$/installheader/" \
+ -e 's:\<pkg-config\>:$(PKG_CONFIG):' \
+ Makefile || die "sed failed"
+}
+
+src_compile() {
+ tc-export CC LD PKG_CONFIG
+ default
+}
+
+src_install() {
+ emake PREFIX="${D}usr" INSTALLMAN="${D}usr/share/man" INSTALLLIB="${D}usr/$(get_libdir)" install || die
+
+ dodoc CHANGELIST README
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}