summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.eu>2020-04-11 21:37:33 +0200
committerRené 'Necoro' Neumann <necoro@necoro.eu>2020-04-11 21:37:33 +0200
commit7c3863752886ffd0f6f78dace6e8b9617e03bdac (patch)
tree85a11dd2d462fa8181a0849d086dc5adc1489294
parent2fd7f58f9a88a849e00385392338a33365244021 (diff)
downloadoverlay-7c3863752886ffd0f6f78dace6e8b9617e03bdac.tar.gz
overlay-7c3863752886ffd0f6f78dace6e8b9617e03bdac.tar.bz2
overlay-7c3863752886ffd0f6f78dace6e8b9617e03bdac.zip
Make old webkit work with new icu
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.4.11-r201.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.4.11-r201.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.4.11-r201.ebuild
index 007ea47..af8aad9 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.4.11-r201.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.4.11-r201.ebuild
@@ -172,6 +172,12 @@ src_configure() {
# Respect CC, otherwise fails on prefix #395875
tc-export CC
+ # revert icu behavior
+ append-cxxflags -DUPRV_BLOCK_MACRO_BEGIN=\"\" -DUPRV_BLOCK_MACRO_END=\"\"
+
+ # disable warnings
+ append-cxxflags -w
+
# Arches without JIT support also need this to really disable it in all places
use jit || append-cppflags -DENABLE_JIT=0 -DENABLE_YARR_JIT=0 -DENABLE_ASSEMBLER=0