summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2016-01-09 10:59:58 +0100
committerRené 'Necoro' Neumann <necoro@necoro.net>2016-01-09 10:59:58 +0100
commitfa07236a35123befdac54bde7ae91ba2dad876a2 (patch)
tree84e37d0a772928771f065892154c89783ad0b5ac
parent5a231c20f9b2951a9ef3412c7f79d560c15f0960 (diff)
downloadoverlay-fa07236a35123befdac54bde7ae91ba2dad876a2.tar.gz
overlay-fa07236a35123befdac54bde7ae91ba2dad876a2.tar.bz2
overlay-fa07236a35123befdac54bde7ae91ba2dad876a2.zip
pass
-rw-r--r--app-admin/pass/files/50pass-gentoo.el9
-rw-r--r--app-admin/pass/pass-9999.ebuild75
2 files changed, 84 insertions, 0 deletions
diff --git a/app-admin/pass/files/50pass-gentoo.el b/app-admin/pass/files/50pass-gentoo.el
new file mode 100644
index 0000000..122d813
--- /dev/null
+++ b/app-admin/pass/files/50pass-gentoo.el
@@ -0,0 +1,9 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'password-store-edit "password-store" nil t)
+(autoload 'password-store-copy "password-store" nil t)
+(autoload 'password-store-init "password-store" nil t)
+(autoload 'password-store-insert "password-store" nil t)
+(autoload 'password-store-generate "password-store" nil t)
+(autoload 'password-store-remove "password-store" nil t)
+(autoload 'password-store-rename "password-store" nil t)
+(autoload 'password-store-version "password-store" nil t)
diff --git a/app-admin/pass/pass-9999.ebuild b/app-admin/pass/pass-9999.ebuild
new file mode 100644
index 0000000..3a316d2
--- /dev/null
+++ b/app-admin/pass/pass-9999.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit bash-completion-r1 git-2 elisp-common
+
+DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely using gpg, pwgen, and git"
+HOMEPAGE="http://www.passwordstore.org/"
+EGIT_REPO_URI="git://git.necoro.eu/others/pass.git"
+EGIT_BRANCH="necoro"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+IUSE="+git X zsh-completion fish-completion emacs dmenu importers elibc_Darwin"
+
+RDEPEND="
+ app-crypt/gnupg
+ app-admin/pwgen
+ >=app-text/tree-1.7.0
+ git? ( dev-vcs/git )
+ X? ( x11-misc/xclip )
+ elibc_Darwin? ( app-misc/getopt )
+ zsh-completion? ( app-shells/gentoo-zsh-completions )
+ fish-completion? ( app-shells/fish )
+ dmenu? ( x11-misc/dmenu x11-misc/xdotool )
+ emacs? ( virtual/emacs )
+"
+
+S="${WORKDIR}/password-store-${PV}"
+
+src_prepare() {
+ use elibc_Darwin || return
+ # use coreutils'
+ sed -i -e 's/openssl base64/base64/g' src/platform/darwin.sh || die
+ # host getopt isn't cool, and we aren't brew (rip out brew reference)
+ sed -i -e '/^GETOPT=/s/=.*$/=getopt-long/' src/platform/darwin.sh || die
+ # make sure we can find "mount"
+ sed -i -e 's:mount -t:/sbin/mount -t:' src/platform/darwin.sh || die
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ use zsh-completion && export FORCE_ZSHCOMP=1
+ use fish-completion && export FORCE_FISHCOMP=1
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ use dmenu && dobin contrib/dmenu/passmenu
+ newbashcomp src/completion/pass.bash-completion pass
+ if use emacs; then
+ elisp-install ${PN} contrib/emacs/*.el
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
+ fi
+ if use importers; then
+ exeinto /usr/share/${PN}/importers
+ doexe contrib/importers/*
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ if use importers; then
+ einfo "To import passwords from other password managers, you may use the"
+ einfo "various importer scripts found in:"
+ einfo " ${ROOT}usr/share/${PN}/importers/"
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}