summaryrefslogtreecommitdiff
path: root/app-laptop/hdapsd/hdapsd-20060409-r1.ebuild
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2008-04-17 01:49:48 +0200
committerRené 'Necoro' Neumann <necoro@necoro.net>2008-04-17 01:49:48 +0200
commit955a9f39aa0b278c6fab7d89d484aeb37fece8b1 (patch)
treecc2596f36840f8b28873142b750a2a202eb10834 /app-laptop/hdapsd/hdapsd-20060409-r1.ebuild
parentd9ec8413744faaba3543bff9773bdad9786260ab (diff)
downloadoverlay-955a9f39aa0b278c6fab7d89d484aeb37fece8b1.tar.gz
overlay-955a9f39aa0b278c6fab7d89d484aeb37fece8b1.tar.bz2
overlay-955a9f39aa0b278c6fab7d89d484aeb37fece8b1.zip
Removed digests and unused ebuilds
Diffstat (limited to '')
-rw-r--r--app-laptop/hdapsd/hdapsd-20060409-r1.ebuild92
1 files changed, 0 insertions, 92 deletions
diff --git a/app-laptop/hdapsd/hdapsd-20060409-r1.ebuild b/app-laptop/hdapsd/hdapsd-20060409-r1.ebuild
deleted file mode 100644
index 481a53b..0000000
--- a/app-laptop/hdapsd/hdapsd-20060409-r1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/hdapsd/hdapsd-20060409-r1.ebuild,v 1.3 2007/08/29 18:55:52 genstef Exp $
-
-inherit eutils linux-info
-
-PROTECT_VER="2"
-
-DESCRIPTION="IBM ThinkPad Harddrive Active Protection disk head parking daemon"
-HOMEPAGE="http://hdaps.sourceforge.net/"
-SRC_URI="mirror://gentoo/${P}.c.bz2
- mirror://gentoo/hdaps_protect-patches-${PROTECT_VER}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-
-IUSE=""
-RDEPEND=""
-
-S="${WORKDIR}"
-
-CONFIG_CHECK="SENSORS_HDAPS"
-ERROR_SENSORS_HDAPS="${P} requires support for HDAPS (CONFIG_SENSORS_HDAPS)"
-
-src_compile() {
- cd "${WORKDIR}"
- gcc ${CFLAGS} "${P}".c -o hdapsd || die "failed to compile"
-}
-
-src_install() {
- dosbin "${WORKDIR}"/hdapsd
- newconfd "${FILESDIR}"/hdapsd.conf hdapsd
- newinitd "${FILESDIR}"/hdapsd.init hdapsd
-
- # Install our kernel patches
- insinto /usr/share/${PN}
- doins *.patch "${FILESDIR}"/hdaps-Z60m.patch
-}
-
-# Yes, this sucks as the source location may change, kernel sources may not be
-# installed, but we try our best anyway
-kernel_patched() {
- get_version
-
- if grep -qs "blk_protect_register" "${KERNEL_DIR}"/block/ll_rw_blk.c ; then
- einfo "Your kernel has already been patched for blk_freeze"
- return 0
- fi
-
- return 1
-}
-
-pkg_config() {
- kernel_patched && return 0
-
- local dir="${ROOT}/usr/share/${PN}"
- local p="hdaps_protect-${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}.patch.gz"
-
- # We need to find our FILESDIR as it's now lost
- if [[ ! -e ${dir}/${p} ]] ; then
- eerror "We don't have a patch for kernel ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH} yet"
- return 1
- fi
-
- if [[ ! -d ${KERNEL_DIR} ]] ; then
- eerror "Kernel sources not found!"
- return 1
- fi
-
- cd "${KERNEL_DIR}"
- epatch "${dir}/${p}"
-
- # This is just a nice to have for me as I use a Z60m myself
- if ! grep -q "Z60m" "${KERNEL_DIR}"/drivers/hwmon/hdaps.c ; then
- epatch "${dir}"/hdaps-Z60m.patch.gz
- fi
-
- echo
- einfo "Now you should rebuild your kernel, its modules"
- einfo "and then install them."
-}
-
-pkg_postinst(){
- [[ -n $(ls "${ROOT}"/sys/block/*/queue/protect 2>/dev/null) ]] && return 0
-
- if ! kernel_patched ; then
- ewarn "Your kernel has NOT been patched for blk_freeze"
- elog "The ebuild can attempt to patch your kernel like so"
- elog " emerge --config =${PF}"
- fi
-}