summaryrefslogtreecommitdiff
path: root/dev-python/bicyclerepair/bicyclerepair-0.7.1.ebuild
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2008-07-22 13:29:43 +0200
committerRené 'Necoro' Neumann <necoro@necoro.net>2008-07-22 13:29:43 +0200
commit9878c542ece140c3ccfb0b8501f4cb68fbeee767 (patch)
tree5b002f68c235bae17056549a59ba7a87a3a087c7 /dev-python/bicyclerepair/bicyclerepair-0.7.1.ebuild
parentbc5205a9035342b6f333b80fee33ce036ddcc37a (diff)
downloadoverlay-9878c542ece140c3ccfb0b8501f4cb68fbeee767.tar.gz
overlay-9878c542ece140c3ccfb0b8501f4cb68fbeee767.tar.bz2
overlay-9878c542ece140c3ccfb0b8501f4cb68fbeee767.zip
Some stuff for bugs
Diffstat (limited to '')
-rw-r--r--dev-python/bicyclerepair/bicyclerepair-0.7.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/bicyclerepair/bicyclerepair-0.7.1.ebuild b/dev-python/bicyclerepair/bicyclerepair-0.7.1.ebuild
new file mode 100644
index 0000000..3be0982
--- /dev/null
+++ b/dev-python/bicyclerepair/bicyclerepair-0.7.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bicyclerepair/bicyclerepair-0.7.1.ebuild,v 1.11 2007/07/04 19:16:33 hawking Exp $
+
+inherit distutils
+
+DESCRIPTION="Bicycle Repair Man is the Python Refactoring Browser,"
+HOMEPAGE="http://bicyclerepair.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bicyclerepair/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE=""
+DEPEND="virtual/python"
+
+src_install() {
+ DOCS="DESIGN"
+ distutils_src_install
+ rm -f ${D}/usr/bin/bikeemacs.bat
+}
+
+pkg_postinst() {
+ # Enable IDLE integration if Python was compiled with tcltk.
+ PYTHON_VER=$(python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:')
+ config_txt=/usr/lib/python${PYTHON_VER}/tools/idle/config.txt
+ if [ -f "${config_txt}" ]; then
+ if [ -z "`grep BicycleRepairMan_Idle ${config_txt}`" ]; then
+ elog "Appending BicycleRepairman to IDLE.."
+ echo "[BicycleRepairMan_Idle]" >> ${config_txt}
+ fi
+ fi
+}