summaryrefslogtreecommitdiff
path: root/net-im/prosody/prosody-0.7.0.ebuild
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2011-03-30 15:36:33 +0200
committerRené 'Necoro' Neumann <necoro@necoro.net>2011-03-30 15:36:33 +0200
commit583c7c78a0b23358c3af4e34302396145e037bca (patch)
treee7b1036e2347780e6fba769b1ba6ab38d398eefc /net-im/prosody/prosody-0.7.0.ebuild
parentb22cbd646e761b632e65a088566d8926155dc510 (diff)
downloadoverlay-583c7c78a0b23358c3af4e34302396145e037bca.tar.gz
overlay-583c7c78a0b23358c3af4e34302396145e037bca.tar.bz2
overlay-583c7c78a0b23358c3af4e34302396145e037bca.zip
Prosody: Use CFLAGS and LDFLAGS
Diffstat (limited to '')
-rw-r--r--net-im/prosody/prosody-0.7.0.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/net-im/prosody/prosody-0.7.0.ebuild b/net-im/prosody/prosody-0.7.0.ebuild
index 25a8902..97229aa 100644
--- a/net-im/prosody/prosody-0.7.0.ebuild
+++ b/net-im/prosody/prosody-0.7.0.ebuild
@@ -43,11 +43,15 @@ src_prepare() {
}
src_configure() {
+ # the configure script is handcrafted (and yells at unknown options)
+ # hence do not use 'econf'
./configure --prefix="/usr" \
--sysconfdir="${JABBER_ETC}" \
--datadir="${JABBER_SPOOL}" \
--with-lua-lib=/usr/$(get_libdir)/lua \
--c-compiler="$(tc-getCC)" --linker="$(tc-getCC)" \
+ --cflags="${CFLAGS}" \
+ --ldflags="${LDFLAGS}" \
--require-config || die "configure failed"
}