summaryrefslogtreecommitdiff
path: root/sys-power/hibernate-script/hibernate-script-1.99.ebuild
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2008-10-30 16:21:19 +0100
committerRené 'Necoro' Neumann <necoro@necoro.net>2008-10-30 16:21:19 +0100
commitcb56d3c67f756e1a3a59556502de4e480fb5a60f (patch)
tree00c0ea126671cb8f479b81145ad0376c56943af2 /sys-power/hibernate-script/hibernate-script-1.99.ebuild
parent1e2b2f3c504115c832a5d254f9d2653757bb0f3f (diff)
downloadoverlay-cb56d3c67f756e1a3a59556502de4e480fb5a60f.tar.gz
overlay-cb56d3c67f756e1a3a59556502de4e480fb5a60f.tar.bz2
overlay-cb56d3c67f756e1a3a59556502de4e480fb5a60f.zip
Add new hibernate-script
Diffstat (limited to '')
-rw-r--r--sys-power/hibernate-script/hibernate-script-1.99.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/sys-power/hibernate-script/hibernate-script-1.99.ebuild b/sys-power/hibernate-script/hibernate-script-1.99.ebuild
new file mode 100644
index 0000000..a1cc9b6
--- /dev/null
+++ b/sys-power/hibernate-script/hibernate-script-1.99.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+PATCH_VERSION="1"
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.tuxonice.net/"
+SRC_URI="http://www.tuxonice.net/downloads/all/${P}.tar.gz
+ mirror://gentoo/${PN}-1.98.1-patches-${PATCH_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="vim-syntax"
+
+DEPEND=""
+RDEPEND="!<media-gfx/splashutils-1.5.2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Our patches
+ epatch "${WORKDIR}"/patches/*.patch
+}
+
+src_install() {
+ BASE_DIR="${D}" \
+ DISTRIBUTION="gentoo" \
+ PREFIX="/usr" \
+ MAN_DIR="${D}/usr/share/man" \
+ "${S}/install.sh" || die "Install failed"
+
+ # hibernate-ram will default to using ram.conf
+ dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+ newinitd "${S}"/init.d/hibernate-cleanup.sh hibernate-cleanup
+
+ # other ebuilds can install scriplets to this dir
+ keepdir /etc/hibernate/scriptlets.d/
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins hibernate.vim
+ fi
+
+ dodoc CHANGELOG README SCRIPTLET-API hibernate.vim
+
+ insinto /etc/logrotate.d
+ newins "${S}"/logrotate.d-hibernate-script hibernate-script
+}
+
+pkg_postinst() {
+ elog
+ elog "You should run the following command to invalidate suspend"
+ elog "images on a clean boot."
+ elog
+ elog " # rc-update add hibernate-cleanup boot"
+ elog
+ elog "See /usr/share/doc/${PF}/README.* for further details."
+ elog
+ elog "Please note that you will need to manually emerge any utilities"
+ elog "(radeontool, vbetool, ...) enabled in the configuration files,"
+ elog "should you wish to use them."
+}