summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--x11-themes/qgtkstyle/Manifest1
-rw-r--r--x11-themes/qgtkstyle/qgtkstyle-9999-r1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/x11-themes/qgtkstyle/Manifest b/x11-themes/qgtkstyle/Manifest
new file mode 100644
index 0000000..4c7db16
--- /dev/null
+++ b/x11-themes/qgtkstyle/Manifest
@@ -0,0 +1 @@
+EBUILD qgtkstyle-9999-r1.ebuild 701 RMD160 afb70eeb4e1bdae67948ff1fe85f1d15bb3d447a SHA1 1ebff7d40ebaf663f0ee8bfb3852142af5c8b024 SHA256 3bb094802d91d36adca881fbe90c26f831c5ed4dd0bb935b13a394d895d0fd50
diff --git a/x11-themes/qgtkstyle/qgtkstyle-9999-r1.ebuild b/x11-themes/qgtkstyle/qgtkstyle-9999-r1.ebuild
new file mode 100644
index 0000000..20088f0
--- /dev/null
+++ b/x11-themes/qgtkstyle/qgtkstyle-9999-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit subversion qt4
+
+ESVN_REPO_URI="svn://labs.trolltech.com/svn/styles"
+ESVN_PROJECT="gtkstyle"
+
+DESCRIPTION="make QT 4.x appplications look like native GTK+"
+HOMEPAGE="http://labs.trolltech.com/page/Projects/Styles/GtkStyle"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.0
+ >=x11-libs/qt-4.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ cd gtkstyle
+ eqmake4 qgtkstyle.pro || die "qmake failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ cd gtkstyle
+ emake INSTALL_ROOT="${D}" install || die "make install failed"
+}