summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--app-office/texmaker/Manifest3
-rw-r--r--app-office/texmaker/files/texmaker-1.71-hunspell.patch67
-rw-r--r--app-office/texmaker/texmaker-1.71-r1.ebuild72
3 files changed, 142 insertions, 0 deletions
diff --git a/app-office/texmaker/Manifest b/app-office/texmaker/Manifest
new file mode 100644
index 0000000..e4fa142
--- /dev/null
+++ b/app-office/texmaker/Manifest
@@ -0,0 +1,3 @@
+AUX texmaker-1.71-hunspell.patch 1701 RMD160 23feb35af205ad2439a994ceed3a041461de318e SHA1 589ee8691da9a8daf2a4c4ff76209db70eccd3e7 SHA256 0e0cf0106209f320c68b7c3670504d6f71f0b9d36f75bd87854a3df9dace9eb9
+DIST texmaker-1.7.1.tar.bz2 1522280 RMD160 37bca67d049fb064b45e09cfbb3453d4cb8bb8da SHA1 055aabf865e8d9baafe2762594469cd2b7d75183 SHA256 e814c68c20663792ca56ba3fb9600841e390463f96dac4f1ba034a35ec454a90
+EBUILD texmaker-1.71-r1.ebuild 1802 RMD160 11a76f1f342ef6b4404d1c2bd63af46fcee124fc SHA1 a88cfa279dd376252245120500278edb14b820b3 SHA256 69fda436a3dc7bdfb848f6fb91f3b3f3106b92ec00d53a516b2c5109eb138723
diff --git a/app-office/texmaker/files/texmaker-1.71-hunspell.patch b/app-office/texmaker/files/texmaker-1.71-hunspell.patch
new file mode 100644
index 0000000..2845196
--- /dev/null
+++ b/app-office/texmaker/files/texmaker-1.71-hunspell.patch
@@ -0,0 +1,67 @@
+diff -r 9450ca28545a spellerdialog.h
+--- a/spellerdialog.h Fri Jun 27 20:29:16 2008 +0200
++++ b/spellerdialog.h Fri Jun 27 20:39:29 2008 +0200
+@@ -13,7 +13,7 @@
+
+ #include "ui_spellerdialog.h"
+ #include "latexeditor.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ #include <QTextCursor>
+
+diff -r 9450ca28545a texmaker.pro
+--- a/texmaker.pro Fri Jun 27 20:29:16 2008 +0200
++++ b/texmaker.pro Fri Jun 27 20:39:29 2008 +0200
+@@ -1,7 +1,8 @@
+ TEMPLATE = app
+ LANGUAGE = C++
+ TARGET = texmaker
+-CONFIG += qt warn_off release
++CONFIG += qt warn_off release link_pkgconfig
++PKGCONFIG = hunspell
+ ###############################
+ HEADERS += texmaker.h \
+ symbollistwidget.h \
+@@ -32,22 +33,7 @@
+ webpublishdialog.h \
+ spellerdialog.h \
+ pstrickslistwidget.h \
+- blockdata.h \
+- hunspell/affentry.hxx \
+- hunspell/affixmgr.hxx \
+- hunspell/atypes.hxx \
+- hunspell/baseaffix.hxx \
+- hunspell/csutil.hxx \
+- hunspell/dictmgr.hxx \
+- hunspell/hashmgr.hxx \
+- hunspell/htypes.hxx \
+- hunspell/hunspell.hxx \
+- hunspell/hunspell.h \
+- hunspell/langnum.hxx \
+- hunspell/license.hunspell \
+- hunspell/phonet.hxx \
+- hunspell/suggestmgr.hxx \
+- hunspell/license.myspell
++ blockdata.h
+ SOURCES += main.cpp \
+ texmaker.cpp \
+ symbollistwidget.cpp \
+@@ -77,16 +63,7 @@
+ aboutdialog.cpp \
+ webpublishdialog.cpp \
+ spellerdialog.cpp \
+- pstrickslistwidget.cpp \
+- hunspell/affentry.cxx \
+- hunspell/affixmgr.cxx \
+- hunspell/csutil.cxx \
+- hunspell/dictmgr.cxx \
+- hunspell/hashmgr.cxx \
+- hunspell/hunspell.cxx \
+- hunspell/phonet.cxx \
+- hunspell/suggestmgr.cxx \
+- hunspell/utf_info.cxx
++ pstrickslistwidget.cpp
+ RESOURCES += texmaker.qrc
+ FORMS += findwidget.ui\
+ gotolinedialog.ui \
diff --git a/app-office/texmaker/texmaker-1.71-r1.ebuild b/app-office/texmaker/texmaker-1.71-r1.ebuild
new file mode 100644
index 0000000..a9fc618
--- /dev/null
+++ b/app-office/texmaker/texmaker-1.71-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/texmaker-1.71-r1.ebuild,v 1.1 2008/05/13 20:34:18 aballier Exp $
+
+EAPI=1
+
+inherit eutils versionator qt4
+
+DESCRIPTION="A nice LaTeX-IDE"
+
+# The upstream version numbering is bad, so we have to remove a dot in the
+# minor version number
+MAJOR="$(get_major_version)"
+MINOR_1="$(($(get_version_component_range 2)/10))"
+MINOR_2="$(($(get_version_component_range 2)%10))"
+if [ ${MINOR_2} -eq "0" ] ; then
+ MY_P="${PN}-${MAJOR}.${MINOR_1}"
+else
+ MY_P="${PN}-${MAJOR}.${MINOR_1}.${MINOR_2}"
+fi
+
+S="${WORKDIR}/${MY_P}"
+HOMEPAGE="http://www.xm1math.net/texmaker/"
+SRC_URI="http://www.xm1math.net/texmaker/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE=""
+
+DEPEND="x11-libs/libX11
+ x11-libs/libXext
+ || ( ( x11-libs/qt-gui x11-libs/qt-core ) >=x11-libs/qt-4.3.0:4 )
+ >=app-text/hunspell-1.2.2"
+
+RDEPEND="${DEPEND}
+ virtual/latex-base
+ app-text/psutils
+ virtual/ghostscript
+ media-libs/netpbm"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-hunspell.patch"
+}
+
+src_compile() {
+ eqmake4 texmaker.pro || die "qmake failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "make install failed"
+
+ insinto /usr/share/pixmaps/texmaker
+ doins utilities/texmaker*.png || die "doins failed."
+ doins utilities/texmaker.svg || die "doins failed."
+
+ dodoc utilities/AUTHORS utilities/CHANGELOG.txt || die "dodoc failed"
+
+ make_desktop_entry texmaker Texmaker "/usr/share/pixmaps/texmaker/texmaker48x48.png" Office
+}
+
+pkg_postinst() {
+ elog "A user manual with many screenshots is available at:"
+ elog "/usr/share/${PN}/usermanual_en.html"
+ elog
+}