summaryrefslogtreecommitdiff
path: root/app-editors/emacs/emacs-23.3-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--app-editors/emacs/emacs-23.3-r2.ebuild (renamed from app-editors/emacs/emacs-23.3-r1.ebuild)47
1 files changed, 30 insertions, 17 deletions
diff --git a/app-editors/emacs/emacs-23.3-r1.ebuild b/app-editors/emacs/emacs-23.3-r2.ebuild
index de3064d..1d2caf7 100644
--- a/app-editors/emacs/emacs-23.3-r1.ebuild
+++ b/app-editors/emacs/emacs-23.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-23.3-r1.ebuild,v 1.1 2011/08/04 17:00:32 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-23.3-r2.ebuild,v 1.7 2011/10/01 03:32:20 phajdan.jr Exp $
EAPI=4
WANT_AUTOMAKE="none"
@@ -14,10 +14,9 @@ SRC_URI="mirror://gnu/emacs/${P}a.tar.bz2
LICENSE="GPL-3 FDL-1.3 BSD as-is MIT W3C unicode PSF-2"
SLOT="23"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="alsa aqua dbus gconf gif gpm gtk gzip-el hesiod jpeg kerberos m17n-lib motif png sound source svg tiff toolkit-scroll-bars X Xaw3d xft +xpm"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="alsa aqua athena dbus gconf gif gpm gtk gzip-el hesiod jpeg kerberos livecd m17n-lib motif png sound source svg tiff toolkit-scroll-bars X Xaw3d xft +xpm"
REQUIRED_USE="aqua? ( !X )"
-RESTRICT="strip"
RDEPEND="sys-libs/ncurses
>=app-admin/eselect-emacs-1.2
@@ -34,7 +33,7 @@ RDEPEND="sys-libs/ncurses
gconf? ( >=gnome-base/gconf-2.26.2 )
gif? ( media-libs/giflib )
jpeg? ( virtual/jpeg )
- png? ( media-libs/libpng )
+ png? ( >=media-libs/libpng-1.4:0 )
svg? ( >=gnome-base/librsvg-2.0 )
tiff? ( media-libs/tiff )
xpm? ( x11-libs/libXpm )
@@ -50,7 +49,10 @@ RDEPEND="sys-libs/ncurses
gtk? ( x11-libs/gtk+:2 )
!gtk? (
Xaw3d? ( x11-libs/libXaw3d )
- !Xaw3d? ( motif? ( >=x11-libs/openmotif-2.3:0 ) )
+ !Xaw3d? (
+ athena? ( x11-libs/libXaw )
+ !athena? ( motif? ( >=x11-libs/openmotif-2.3:0 ) )
+ )
)
)"
@@ -72,7 +74,6 @@ S="${WORKDIR}/emacs-${FULL_VERSION}"
src_prepare() {
EPATCH_SUFFIX=patch epatch
- epatch "${FILESDIR}/emacs-23.3-wide-chars-fix.patch"
sed -i \
-e "s:/usr/lib/crtbegin.o:$(`tc-getCC` -print-file-name=crtbegin.o):g" \
@@ -93,6 +94,8 @@ src_prepare() {
|| die "unable to sed configure.in"
fi
+ epatch "${FILESDIR}/emacs-23.3-wide-chars-fix.patch"
+
eautoreconf
}
@@ -129,15 +132,16 @@ src_configure() {
myconf="${myconf} $(use_with gif) $(use_with jpeg)"
myconf="${myconf} $(use_with png) $(use_with svg rsvg)"
myconf="${myconf} $(use_with tiff) $(use_with xpm)"
- myconf="${myconf} $(use_with xft)"
if use xft; then
+ myconf="${myconf} --with-xft"
myconf="${myconf} $(use_with m17n-lib libotf)"
myconf="${myconf} $(use_with m17n-lib m17n-flt)"
else
+ myconf="${myconf} --without-xft"
myconf="${myconf} --without-libotf --without-m17n-flt"
use m17n-lib && ewarn \
- "USE flag \"m17n-lib\" has no effect because xft is not set."
+ "USE flag \"m17n-lib\" has no effect if \"xft\" is not set."
fi
# GTK+ is the default toolkit if USE=gtk is chosen with other
@@ -146,9 +150,9 @@ src_configure() {
if use gtk; then
einfo "Configuring to build with GIMP Toolkit (GTK+)"
myconf="${myconf} --with-x-toolkit=gtk"
- elif use Xaw3d; then
- einfo "Configuring to build with Xaw3d (Athena/Lucid) toolkit"
- myconf="${myconf} --with-x-toolkit=athena"
+ elif use Xaw3d || use athena; then
+ einfo "Configuring to build with Athena/Lucid toolkit"
+ myconf="${myconf} --with-x-toolkit=lucid $(use_with Xaw3d xaw3d)"
elif use motif; then
einfo "Configuring to build with Motif toolkit"
myconf="${myconf} --with-x-toolkit=motif"
@@ -158,9 +162,9 @@ src_configure() {
fi
local f tk=
- for f in gtk Xaw3d motif; do
+ for f in gtk Xaw3d athena motif; do
use ${f} || continue
- [ "${tk}" ] \
+ [[ ${tk} ]] \
&& ewarn "USE flag \"${f}\" ignored (superseded by \"${tk}\")"
tk="${tk}${tk:+ }${f}"
done
@@ -193,6 +197,8 @@ src_configure() {
src_compile() {
export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
+ # set last component of emacs-version to (package revision + 1)
+ touch src/emacs-${FULL_VERSION}.${PR#r}
emake CC="$(tc-getCC)"
}
@@ -267,7 +273,7 @@ src_install () {
pkg_preinst() {
# move Info dir file to correct name
local infodir=/usr/share/info/${EMACS_SUFFIX} f
- if [ -f "${ED}"${infodir}/dir.orig ]; then
+ if [[ -f ${ED}${infodir}/dir.orig ]]; then
mv "${ED}"${infodir}/dir{.orig,} || die "moving info dir failed"
else
# this should not happen in EAPI 4
@@ -285,12 +291,19 @@ pkg_preinst() {
pkg_postinst() {
local f
for f in "${EROOT}"/var/lib/games/emacs/{snake,tetris}-scores; do
- [ -e "${f}" ] || touch "${f}"
+ [[ -e ${f} ]] || touch "${f}"
done
chown "${GAMES_USER_DED:-games}" "${EROOT}"/var/lib/games/emacs
elisp-site-regen
- eselect emacs update ifunset
+
+ if use livecd; then
+ # force an update of the emacs symlink for the livecd/dvd,
+ # because some microemacs packages set it with USE=livecd
+ eselect emacs update
+ else
+ eselect emacs update ifunset
+ fi
if use X; then
echo