summaryrefslogtreecommitdiff
path: root/app-emulation/virtualbox/files/virtualbox-ose-asneeded.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/virtualbox/files/virtualbox-ose-asneeded.patch')
-rw-r--r--app-emulation/virtualbox/files/virtualbox-ose-asneeded.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/app-emulation/virtualbox/files/virtualbox-ose-asneeded.patch b/app-emulation/virtualbox/files/virtualbox-ose-asneeded.patch
new file mode 100644
index 0000000..2eee125
--- /dev/null
+++ b/app-emulation/virtualbox/files/virtualbox-ose-asneeded.patch
@@ -0,0 +1,16 @@
+--- src/libs/xpcom18a4/Makefile.kmk
++++ src/libs/xpcom18a4/Makefile.kmk
+@@ -469,9 +469,10 @@
+ libIDL_config_cflags := $(shell $(VBOX_LIBIDL_CONFIG) --cflags)
+ libIDL_config_libs := $(shell $(VBOX_LIBIDL_CONFIG) --libs)
+ xpidl_CFLAGS = \
+- $(libIDL_config_cflags)
+- xpidl_LDFLAGS = \
+- $(libIDL_config_libs)
++ $(shell pkg-config --cflags libIDL-2.0)
++ xpidl_LDFLAGS = $(shell pkg-config --libs-only-L libIDL-2.0)
++ xpidl_LIBS.linux = $(shell pkg-config --libs-only-l libIDL-2.0 | sed -e 's/-l//g')
++
+ endif
+
+ #