summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/htmlgen/Manifest2
-rw-r--r--dev-python/htmlgen/htmlgen-2.2.2.ebuild57
-rw-r--r--dev-python/paste/Manifest2
-rw-r--r--dev-python/paste/paste-1.6.ebuild53
4 files changed, 0 insertions, 114 deletions
diff --git a/dev-python/htmlgen/Manifest b/dev-python/htmlgen/Manifest
deleted file mode 100644
index c9d8cd4..0000000
--- a/dev-python/htmlgen/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST HTMLgen.tgz 316415 RMD160 bb32b2822f7ce8e49eb42853aff330429df073de SHA1 a34b9c1f9cf5536a548c66522213ac9fee1b43cd SHA256 f3b39b4b07b5dd318780ad0e9b8b3c524a54138537697dd7966223f314d2177d
-EBUILD htmlgen-2.2.2.ebuild 1516 RMD160 be11b4994918a74d31b2ad0e8ac1d9de4a261c83 SHA1 02e9255b1f7dce57099d27ac4816173937f02ad2 SHA256 74676d11d3b94db70fb9f22f393cecee6d9bdffef2eeeca23358feb06859756a
diff --git a/dev-python/htmlgen/htmlgen-2.2.2.ebuild b/dev-python/htmlgen/htmlgen-2.2.2.ebuild
deleted file mode 100644
index b6d9879..0000000
--- a/dev-python/htmlgen/htmlgen-2.2.2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/htmlgen/htmlgen-2.2.2.ebuild,v 1.12 2006/07/12 15:39:25 agriffis Exp $
-
-inherit python
-
-MY_P="HTMLgen"
-DESCRIPTION="HTMLgen - Python modules for the generation of HTML documents"
-HOMEPAGE="http://starship.python.net/crew/friedrich/HTMLgen/html/main.html"
-SRC_URI="http://starship.python.net/crew/friedrich/${MY_P}.tgz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="ia64 ppc x86"
-IUSE="doc"
-
-DEPEND="virtual/python
- dev-python/imaging"
-
-S="${WORKDIR}/${MY_P}"
-
-src_compile() {
- # nothing to do
- :
-}
-
-src_install() {
- # doing this manually because their build scripts suck
- local files="HTMLgen.py HTMLcolors.py HTMLutil.py HTMLcalendar.py \
- barchart.py colorcube.py imgsize.py NavLinks.py Formtools.py \
- ImageH.py ImageFileH.py ImagePaletteH.py GifImagePluginH.py \
- JpegImagePluginH.py PngImagePluginH.py"
-
- touch __init__.py
-
- insinto $(python_get_sitedir)/htmlgen
- doins $files __init__.py || die "doins failed"
-
- if use doc; then
- # fix the image locations in the docs
- sed -i -e "s;../image/;image/;g" html/* || die "sed failed"
- dohtml html/*
- dohtml -r image
- fi
- dodoc README
-}
-
-pkg_postinst() {
- python_mod_optimize $(python_get_sitedir)/htmlgen
-
- ewarn "htmlgen now resides in its own subdirectory"
- ewarn "so you need to do \"from htmlgen import HTMLgen\" instead of \"import HTMLgen\""
-}
-
-pkg_postrm () {
- python_mod_cleanup $(python_get_sitedir)/htmlgen
-}
diff --git a/dev-python/paste/Manifest b/dev-python/paste/Manifest
deleted file mode 100644
index f3c6ff5..0000000
--- a/dev-python/paste/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST Paste-1.6.tar.gz 368163 RMD160 00abce4ed39384ee8aad27681f4351a985f57a7c SHA1 45de5772a0a8cec45b70cdc3cb9aa0e30e5d0f0b SHA256 d2fe1c21fa2feb3923c0a7a862811c51a70412595498eed91e63b1a74a20ca47
-EBUILD paste-1.6.ebuild 1213 RMD160 da4de06654b1a50474f7601888cf0592b010e2af SHA1 a752844f70a40a2fd9e477efa94e1fa2203f993f SHA256 232982c256791b8fbfd300684f79bc0714ce734b9f9c49de6ab2c487dd5efb67
diff --git a/dev-python/paste/paste-1.6.ebuild b/dev-python/paste/paste-1.6.ebuild
deleted file mode 100644
index bc2192d..0000000
--- a/dev-python/paste/paste-1.6.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/paste/paste-1.6.ebuild,v 1.2 2008/05/13 13:21:08 hawking Exp $
-
-NEED_PYTHON=2.4
-
-inherit distutils
-
-KEYWORDS="~amd64 ~x86"
-
-MY_PN=Paste
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Tools for using a Web Server Gateway Interface stack"
-HOMEPAGE="http://pythonpaste.org"
-SRC_URI="http://cheeseshop.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-LICENSE="MIT"
-SLOT="0"
-IUSE="doc flup openid"
-
-RDEPEND="flup? ( dev-python/flup )
- openid? ( dev-python/python-openid )"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/pudge dev-python/buildutils )"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- distutils_src_unpack
-
- sed -i \
- -e '/highlighter/d' \
- setup.cfg || die "sed failed"
-}
-
-src_compile() {
- addpredict "/root/.gconfd"
- addpredict "/root/.gconf"
-
- distutils_src_compile
- if use doc ; then
- einfo "Generating docs as requested..."
- PYTHONPATH=. "${python}" setup.py pudge || die "generating docs failed"
- fi
-}
-
-src_install() {
- distutils_src_install
- use doc && dohtml -r docs/html/*
-}
-
-# src_test() needs py.test but there's no release yet