summaryrefslogtreecommitdiff
path: root/sys-power/hibernate-script
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/hibernate-script')
-rw-r--r--sys-power/hibernate-script/Manifest3
-rw-r--r--sys-power/hibernate-script/hibernate-script-1.99.ebuild69
2 files changed, 72 insertions, 0 deletions
diff --git a/sys-power/hibernate-script/Manifest b/sys-power/hibernate-script/Manifest
new file mode 100644
index 0000000..5e3c6fb
--- /dev/null
+++ b/sys-power/hibernate-script/Manifest
@@ -0,0 +1,3 @@
+DIST hibernate-script-1.98.1-patches-1.tar.bz2 708 RMD160 17bdd4a7bbfeabeee0c00cc615ef2279c4144f5a SHA1 a6567d2d78350894a1683792b0ea73e2b22b21f4 SHA256 920cfa1b77d9439ef7a3c64e686faed4b6b9d8800a0b381ba62e07b2e78b34c6
+DIST hibernate-script-1.99.tar.gz 113644 RMD160 baf2554925c38683a583c5ad65f346f0bc4e9302 SHA1 f45672032322ea9f987f3bcb5380df7638e605e7 SHA256 65d4b5eae6a29fbc15374a963ec7c68af2312717084c0fac18ba9421a8ce3f55
+EBUILD hibernate-script-1.99.ebuild 1683 RMD160 9ff0671e382b953b992534e8fd71af2cd978e22b SHA1 1fe9586fbd4c2b889a41192645845dc6622f9060 SHA256 90ce5adcf53417cf5214201de4f88880c5e8b78bb325e3af0851ebe2d5af47f8
diff --git a/sys-power/hibernate-script/hibernate-script-1.99.ebuild b/sys-power/hibernate-script/hibernate-script-1.99.ebuild
new file mode 100644
index 0000000..a1cc9b6
--- /dev/null
+++ b/sys-power/hibernate-script/hibernate-script-1.99.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+PATCH_VERSION="1"
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.tuxonice.net/"
+SRC_URI="http://www.tuxonice.net/downloads/all/${P}.tar.gz
+ mirror://gentoo/${PN}-1.98.1-patches-${PATCH_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="vim-syntax"
+
+DEPEND=""
+RDEPEND="!<media-gfx/splashutils-1.5.2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Our patches
+ epatch "${WORKDIR}"/patches/*.patch
+}
+
+src_install() {
+ BASE_DIR="${D}" \
+ DISTRIBUTION="gentoo" \
+ PREFIX="/usr" \
+ MAN_DIR="${D}/usr/share/man" \
+ "${S}/install.sh" || die "Install failed"
+
+ # hibernate-ram will default to using ram.conf
+ dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+ newinitd "${S}"/init.d/hibernate-cleanup.sh hibernate-cleanup
+
+ # other ebuilds can install scriplets to this dir
+ keepdir /etc/hibernate/scriptlets.d/
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins hibernate.vim
+ fi
+
+ dodoc CHANGELOG README SCRIPTLET-API hibernate.vim
+
+ insinto /etc/logrotate.d
+ newins "${S}"/logrotate.d-hibernate-script hibernate-script
+}
+
+pkg_postinst() {
+ elog
+ elog "You should run the following command to invalidate suspend"
+ elog "images on a clean boot."
+ elog
+ elog " # rc-update add hibernate-cleanup boot"
+ elog
+ elog "See /usr/share/doc/${PF}/README.* for further details."
+ elog
+ elog "Please note that you will need to manually emerge any utilities"
+ elog "(radeontool, vbetool, ...) enabled in the configuration files,"
+ elog "should you wish to use them."
+}