summaryrefslogtreecommitdiff
path: root/www-apps/cgit/cgit-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--www-apps/cgit/cgit-9999.ebuild (renamed from www-apps/cgit/cgit-0.8.3.4.ebuild)48
1 files changed, 22 insertions, 26 deletions
diff --git a/www-apps/cgit/cgit-0.8.3.4.ebuild b/www-apps/cgit/cgit-9999.ebuild
index c7761bf..04dccdb 100644
--- a/www-apps/cgit/cgit-0.8.3.4.ebuild
+++ b/www-apps/cgit/cgit-9999.ebuild
@@ -1,32 +1,36 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/cgit/cgit-9999.ebuild,v 1.5 2012/06/01 04:30:38 zmedico Exp $
-EAPI="2"
+EAPI="4"
WEBAPP_MANUAL_SLOT="yes"
-inherit webapp eutils
+inherit webapp multilib user git-2
[[ -z "${CGIT_CACHEDIR}" ]] && CGIT_CACHEDIR="/var/cache/${PN}/"
-GIT_V="1.7.3"
+GIT_V="1.7.4"
DESCRIPTION="a fast web-interface for git repositories"
HOMEPAGE="http://hjemli.net/git/cgit/about/"
-SRC_URI="mirror://kernel/software/scm/git/git-${GIT_V}.tar.bz2
- http://hjemli.net/git/cgit/snapshot/${P}.tar.bz2"
+SRC_URI=""
+EGIT_REPO_URI="git://git.necoro.eu/others/${PN}"
+EGIT_BRANCH="sendfile"
+EGIT_HAS_SUBMODULES="yes"
+EGIT_PRUNE="yes"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
+KEYWORDS=""
+IUSE="doc highlight"
RDEPEND="
dev-vcs/git
sys-libs/zlib
dev-libs/openssl
virtual/httpd-cgi
+ highlight? ( app-text/highlight )
"
# ebuilds without WEBAPP_MANUAL_SLOT="yes" are broken
DEPEND="${RDEPEND}
@@ -40,29 +44,20 @@ pkg_setup() {
enewuser "${PN}"
}
-src_prepare() {
- rmdir git || die
- mv "${WORKDIR}"/git-"${GIT_V}" git || die
-
- sed -i \
- -e "/^CACHE_ROOT =/s:/var/cache/cgit:${CGIT_CACHEDIR}:" \
- Makefile || die
-}
-
src_compile() {
- emake || die
- if use doc ; then
- emake man-doc || die
- fi
+ emake
+ use doc && emake doc-man
}
src_install() {
webapp_src_preinst
emake \
+ prefix="${EPREFIX}"/usr \
+ libdir="${EPREFIX}"/usr/$(get_libdir) \
CGIT_SCRIPT_PATH="${MY_CGIBINDIR}" \
CGIT_DATA_PATH="${MY_HTDOCSDIR}" \
- DESTDIR="${D}" install || die
+ DESTDIR="${D}" install
insinto /etc
doins "${FILESDIR}"/cgitrc
@@ -74,11 +69,12 @@ src_install() {
webapp_src_install
keepdir "${CGIT_CACHEDIR}"
- fowners ${PN}:${PN} "${CGIT_CACHEDIR}"
- fperms 700 "${CGIT_CACHEDIR}"
+ #fowners ${PN}:${PN} "${CGIT_CACHEDIR}"
+ #fperms 700 "${CGIT_CACHEDIR}"
}
pkg_postinst() {
+ webapp_pkg_postinst
ewarn "If you intend to run cgit using web server's user"
- ewarn "you should change /var/cache/cgit/ permissions."
+ ewarn "you should change ${CGIT_CACHEDIR} permissions."
}