summaryrefslogtreecommitdiff
path: root/www-servers/hiawatha/hiawatha-9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/hiawatha/hiawatha-9.0.ebuild')
-rw-r--r--www-servers/hiawatha/hiawatha-9.0.ebuild93
1 files changed, 93 insertions, 0 deletions
diff --git a/www-servers/hiawatha/hiawatha-9.0.ebuild b/www-servers/hiawatha/hiawatha-9.0.ebuild
new file mode 100644
index 0000000..703129c
--- /dev/null
+++ b/www-servers/hiawatha/hiawatha-9.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+CMAKE_MIN_VERSION="2.8.4"
+
+M_P="monitor-0.6"
+
+inherit cmake-utils
+
+DESCRIPTION="Advanced and secure webserver"
+HOMEPAGE="http://www.hiawatha-webserver.org"
+SRC_URI="http://www.hiawatha-webserver.org/files/${P}.tar.gz
+ monitor? ( http://www.hiawatha-webserver.org/files/${M_P}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug +cache chroot ipv6 monitor +rewrite rproxy ssl tomahawk xslt"
+
+DEPEND="
+ ssl? ( >=net-libs/polarssl-1.2 )
+ xslt? ( dev-libs/libxslt
+ dev-libs/libxml2 )
+ "
+
+RDEPEND="${DEPEND}
+ monitor? ( virtual/cron
+ =dev-lang/php-5*[mysql]
+ virtual/mysql )
+ "
+
+REQUIRED_USE="monitor? ( xslt )"
+
+PATCHES=("${FILESDIR}"/${P}-no-bundled-polarssl.patch)
+
+src_configure() {
+ if use debug; then
+ CMAKE_BUILD_TYPE="RelWithDebInfo"
+ else
+ CMAKE_BUILD_TYPE="Gentoo"
+ fi
+ if use kernel_linux; then
+ myargs=" -DENABLE_LOADCHECK=ON "
+ fi
+
+ mycmakeargs=(
+ $(cmake-utils_use_enable cache CACHE)
+ $(cmake-utils_use_enable chroot CHROOT)
+ $(cmake-utils_use_enable ipv6 IPV6)
+ $(cmake-utils_use_enable debug DEBUG)
+ $(cmake-utils_use_enable monitor MONITOR)
+ $(cmake-utils_use_enable rewrite TOOLKIT)
+ $(cmake-utils_use_enable rproxy RPROXY)
+ $(cmake-utils_use_enable ssl SSL)
+ $(cmake-utils_use_enable xslt XSLT)
+ -DLOG_DIR:STRING=/var/log/hiawatha
+ -DPID_DIR:STRING=/var/run
+ -DWEBROOT_DIR:STRING=/var/www/hiawatha
+ -DWORK_DIR:STRING=/var/lib/hiawatha
+ -DCONFIG_DIR:STRING=/etc/hiawatha
+ ${myargs}
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ newinitd "${FILESDIR}"/hiawatha.initd hiawatha
+
+ keepdir /var/l{ib,og}/hiawatha
+ if use monitor; then
+ insinto /usr/share/"${PN}"/monitor
+ doins -r "${WORKDIR}"/monitor/*
+ newdoc "${WORKDIR}"/monitor/README README.monitor
+ newdoc "${WORKDIR}"/monitor/ChangeLog ChangeLog.monitor
+ fi
+}
+
+pkg_postinst() {
+ if use monitor; then
+ einfo "You requested the server monitor feature."
+ einfo "The required files have been installed to ${ED}/usr/share/"${PN}"/monitor."
+ einfo "Please read the Monitor HOWTO"
+ einfo "from http://www.hiawatha-webserver.org/howto/monitor"
+ einfo "and configure your virtual server - i.e. add"
+ einfo "the required string in the config files, setup mysql databases"
+ einfo "and add a cron job."
+ fi
+}
rtato/gui/templates/ui/PreferenceWindow.ui?h=0.13&id=eb2d5a7590bbbe91abe5d8f8a79624d6f756daba&follow=1'>added systraynecoro6-20/+211 2007-04-25added noroot-optionnecoro7-11/+57 2007-04-24changed TODO and ChangeLognecoro2-1/+3 2007-04-24using (kde/gk)sunecoro2-2/+2 2007-04-24add application icon and desktop filenecoro1-2/+2 2007-04-24add application icon and desktop filenecoro7-4/+25 2007-04-24moved *.glade and *.ui to one directory to omit the change of the config.py ↵necoro8-5/+2538 each time 2007-04-24moved *.glade and *.ui to one directory to omit the change of the config.py ↵necoro5-1191/+0 each time 2007-04-24moved *.glade and *.ui to one directory to omit the change of the config.py ↵necoro1-1340/+0 each time 2007-04-24added dialogs to warn you when the queue is running on quitting portatonecoro8-214/+267 2007-04-20Made qt plugin-ready; lots of documentationnecoro15-81/+351 2007-04-18nomsgnecoro1-1/+0 2007-04-18finished Qt-Frontendnecoro5-15/+117 2007-04-17marking installed packages in pkglistnecoro5-14/+50 2007-04-16added ebuild window for Qt-Frontendnecoro4-2/+229 2007-04-16added preferences for Qt-Frontendnecoro9-279/+710 2007-04-13Improved masking display and made most of the Qt-Frontend worknecoro7-35/+334 2007-04-10Some more functionality for the Qt-Frontend (complete emerge)necoro8-217/+347 2007-04-07Some more functionality for the Qt-Frontendnecoro11-88/+463 2007-04-07Added Qt-Terminalnecoro4-4/+213 2007-04-06First qt draftnecoro6-1/+796 2007-04-04showed masked packages unmasked by the user similar to stable marked testing ↵necoro5-13/+40 packages 2007-03-31changed changelognecoro1-1/+2 2007-03-31Some small changes for etcproposals 1.1necoro1-2/+2 2007-03-31Some small changes for etcproposals 1.1necoro2-3/+3 2007-03-31Some small changes for etcproposals 1.1necoro1-6/+13 2007-03-31Allowed Plugins to have a menunecoro7-201/+315 2007-03-15Added etc-proposals pluginnecoro7-28/+121 2007-03-10Added USE_EXPAND-supportnecoro5-11/+63 2007-03-10Added plugin-data to about-dialognecoro3-197/+264