summaryrefslogtreecommitdiff
path: root/x11-libs/cairo/files
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/cairo/files')
-rw-r--r--x11-libs/cairo/files/cairo-1.10.0-buggy_gradients.patch17
-rw-r--r--x11-libs/cairo/files/cairo-1.10.2-interix.patch36
-rw-r--r--x11-libs/cairo/files/cairo-1.10.2-qt-surface.patch55
-rw-r--r--x11-libs/cairo/files/cairo-1.8.8-interix.patch16
4 files changed, 0 insertions, 124 deletions
diff --git a/x11-libs/cairo/files/cairo-1.10.0-buggy_gradients.patch b/x11-libs/cairo/files/cairo-1.10.0-buggy_gradients.patch
deleted file mode 100644
index a58c2f8..0000000
--- a/x11-libs/cairo/files/cairo-1.10.0-buggy_gradients.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-http://repos.archlinux.org/wsvn/packages/cairo/trunk/cairo-1.10.0-buggy_gradients.patch
-http://bugs.gentoo.org/336696
-
---- src/cairo-xlib-display.c
-+++ src/cairo-xlib-display.c
-@@ -353,11 +353,7 @@
- /* Prior to Render 0.10, there is no protocol support for gradients and
- * we call function stubs instead, which would silently consume the drawing.
- */
--#if RENDER_MAJOR == 0 && RENDER_MINOR < 10
- display->buggy_gradients = TRUE;
--#else
-- display->buggy_gradients = FALSE;
--#endif
- display->buggy_pad_reflect = FALSE;
- display->buggy_repeat = FALSE;
-
diff --git a/x11-libs/cairo/files/cairo-1.10.2-interix.patch b/x11-libs/cairo/files/cairo-1.10.2-interix.patch
deleted file mode 100644
index 3333e3e..0000000
--- a/x11-libs/cairo/files/cairo-1.10.2-interix.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-commit 95f6f7a174ca096a3d3dbe84ff220d166d1e2baa
-Author: Uli Schlachter <psychon@znc.in>
-Date: Fri Oct 22 11:54:57 2010 +0200
-
- Make both versions of _cairo_lround consistent again
-
- Commit c0008242b0f made cairo use libm's lround instead of its own _cairo_lround
- by default. However, since commit ce58f874 from 2006, _cairo_lround does
- arithmetic rounding instead of away-from-zero rounding (before said commit, it
- was using baker's rounding).
-
- So to make the rounding of _cairo_lround be independent from
- DISABLE_SOME_FLOATING_POINT, we have to use another function. Turns out that
- _cairo_round already does the same thing that _cairo_lround does. Their only
- difference is the return type.
-
- Signed-off-by: Uli Schlachter <psychon@znc.in>
- Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
-
-diff --git a/src/cairoint.h b/src/cairoint.h
-index 53c87e5..539d92e 100644
---- a/src/cairoint.h
-+++ b/src/cairoint.h
-@@ -968,7 +968,11 @@ _cairo_round (double r)
- cairo_private int
- _cairo_lround (double d) cairo_const;
- #else
--#define _cairo_lround lround
-+static inline int cairo_const
-+_cairo_lround (double r)
-+{
-+ return _cairo_round (r);
-+}
- #endif
-
- cairo_private uint16_t
diff --git a/x11-libs/cairo/files/cairo-1.10.2-qt-surface.patch b/x11-libs/cairo/files/cairo-1.10.2-qt-surface.patch
deleted file mode 100644
index cf0b57a..0000000
--- a/x11-libs/cairo/files/cairo-1.10.2-qt-surface.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-diff -ruN cairo-1.10.2-0-vanilla/src/cairo-qt-surface.cpp cairo-1.10.2/src/cairo-qt-surface.cpp
---- cairo-1.10.2-0-vanilla/src/cairo-qt-surface.cpp 2010-12-25 15:21:34.000000000 +0100
-+++ cairo-1.10.2/src/cairo-qt-surface.cpp 2011-12-20 22:59:30.000000000 +0100
-@@ -61,7 +61,9 @@
- #include <QtGui/QX11Info>
- #include <QtCore/QVarLengthArray>
-
--#if (QT_VERSION >= QT_VERSION_CHECK(4, 7, 0)) || defined(QT_GLYPHS_API_BACKPORT)
-+#if (QT_VERSION >= QT_VERSION_CHECK(4, 8, 0))
-+#include <QtGui/QGlyphRun>
-+#elif (QT_VERSION >= QT_VERSION_CHECK(4, 7, 0)) || defined(QT_GLYPHS_API_BACKPORT)
- extern void qt_draw_glyphs(QPainter *, const quint32 *glyphs, const QPointF *positions, int count);
- #endif
-
-@@ -1370,7 +1372,39 @@
- cairo_clip_t *clip,
- int *remaining_glyphs)
- {
--#if (QT_VERSION >= QT_VERSION_CHECK(4, 7, 0)) || defined(QT_GLYPHS_API_BACKPORT)
-+#if (QT_VERSION >= QT_VERSION_CHECK(4, 8, 0)) && !defined(QT_NO_RAWFONT)
-+ cairo_qt_surface_t *qs = (cairo_qt_surface_t *) abstract_surface;
-+
-+ // pick out the colour to use from the cairo source
-+ cairo_solid_pattern_t *solid = (cairo_solid_pattern_t*) source;
-+ // documentation says you have to freeze the cache, but I don't believe it
-+ _cairo_scaled_font_freeze_cache(scaled_font);
-+
-+ QColor tempColour(solid->color.red * 255, solid->color.green * 255, solid->color.blue * 255);
-+ QVector<QPointF> positions(num_glyphs);
-+ QVector<unsigned int> glyphss(num_glyphs);
-+ FT_Face face = cairo_ft_scaled_font_lock_face (scaled_font);
-+ const FT_Size_Metrics& ftMetrics = face->size->metrics;
-+ QFont font(face->family_name);
-+ font.setStyleStrategy(QFont::NoFontMerging);
-+ font.setBold(face->style_flags & FT_STYLE_FLAG_BOLD);
-+ font.setItalic(face->style_flags & FT_STYLE_FLAG_ITALIC);
-+ font.setKerning(face->face_flags & FT_FACE_FLAG_KERNING);
-+ font.setPixelSize(ftMetrics.y_ppem);
-+ cairo_ft_scaled_font_unlock_face(scaled_font);
-+ qs->p->setFont(font);
-+ qs->p->setPen(tempColour);
-+ for (int currentGlyph = 0; currentGlyph < num_glyphs; currentGlyph++) {
-+ positions.append(QPointF(glyphs[currentGlyph].x, glyphs[currentGlyph].y));
-+ glyphss.append(glyphs[currentGlyph].index);
-+ }
-+ QGlyphRun qglyphs;
-+ qglyphs.setGlyphIndexes(glyphss);
-+ qglyphs.setPositions(positions);
-+ qs->p->drawGlyphRun(QPointF(), qglyphs);
-+ _cairo_scaled_font_thaw_cache(scaled_font);
-+ return CAIRO_INT_STATUS_SUCCESS;
-+#elif (QT_VERSION >= QT_VERSION_CHECK(4, 7, 0)) || defined(QT_GLYPHS_API_BACKPORT)
- cairo_qt_surface_t *qs = (cairo_qt_surface_t *) abstract_surface;
-
- // pick out the colour to use from the cairo source
diff --git a/x11-libs/cairo/files/cairo-1.8.8-interix.patch b/x11-libs/cairo/files/cairo-1.8.8-interix.patch
deleted file mode 100644
index dc20714..0000000
--- a/x11-libs/cairo/files/cairo-1.8.8-interix.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -ru cairo-1.8.8.orig/build/configure.ac.tools cairo-1.8.8/build/configure.ac.tools
---- cairo-1.8.8.orig/build/configure.ac.tools 2009-09-30 13:36:42 +0200
-+++ cairo-1.8.8/build/configure.ac.tools 2009-09-30 13:50:50 +0200
-@@ -21,5 +21,12 @@
- *) PKGCONFIG_REQUIRES="Requires.private"; ;;
- esac
-
-+dnl hmm... on interix, things go really bad with Requires.private, since libpng12
-+dnl is missing on the final link commands, so gtk+'s configure checks for cairo
-+dnl fail miserably with unresolved symbols to it.
-+case "$host_os" in
-+interix*) PKGCONFIG_REQUIRES="Requires" ;;
-+esac
-+
- AC_SUBST(PKGCONFIG_REQUIRES)
-