summaryrefslogtreecommitdiff
path: root/x11-misc/zim/zim-0.25.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/zim/zim-0.25.ebuild')
-rw-r--r--x11-misc/zim/zim-0.25.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/x11-misc/zim/zim-0.25.ebuild b/x11-misc/zim/zim-0.25.ebuild
deleted file mode 100644
index 0528405..0000000
--- a/x11-misc/zim/zim-0.25.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/zim/zim-0.23.ebuild,v 1.1 2008/05/11 14:24:35 drac Exp $
-
-EAPI=1
-
-inherit fdo-mime perl-module
-
-MY_P=${P/z/Z}
-
-DESCRIPTION="A desktop wiki"
-HOMEPAGE="http://www.zim-wiki.org"
-SRC_URI="http://www.zim-wiki.org/downloads/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="latex screenshot spell"
-
-DEPEND=">=dev-lang/perl-5.8
- >=x11-libs/gtk+-2.10
- virtual/perl-Storable
- virtual/perl-File-Spec
- >=dev-perl/File-BaseDir-0.03
- >=dev-perl/File-MimeInfo-0.12
- >=dev-perl/File-DesktopEntry-0.03
- >=dev-perl/gtk2-perl-1.040
- x11-misc/xdg-utils"
-
-RDEPEND="${DEPEND}
- latex? ( virtual/latex-base app-text/dvipng )
- screenshot? ( media-gfx/scrot )
- spell? ( dev-perl/gtk2-spell )"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=( "${FILESDIR}/${PN}-0.25-disable-update-databases.patch" )
-
-add_plugin() {
- name=$1
-
- sed -i -e "s/\(plugins=.*\)\$/\1,$name/" "${S}/share/zim/default.conf"
-}
-
-src_compile() {
- add_plugin TrayIcon
- use latex && add_plugin EquationEditor
- use screenshot && add_plugin InsertScreenshot
- use spell && add_plugin Spell
-
- perl-module_src_compile
-}
-
-pkg_postinst() {
- perl-module_pkg_postinst
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
- einfo "Adding icon resource ..."
- xdg-icon-resource install --context mimetypes --size 64 "${ROOT}usr/share/pixmaps/zim.png" text-x-zim-notebook
-}
-
-pkg_postrm() {
- perl-module_pkg_postrm
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
-
- # XXX: for up-/downgrades postinst is run first
- # thus we are then reverting the "xdg-icon-resource install" call and
- # nothing gets installed =/
- einfo "Removing icon resource ..."
- xdg-icon-resource uninstall --context mimetypes --size 64 text-x-zim-notebook
-}
n>/+8 2021-02-16Fix CRLF endingRené 'Necoro' Neumann1-57/+57 2021-02-16Increment go-version to 1.16René 'Necoro' Neumann3-5/+5 2021-02-16Use go-embed for templates instead of inline strings.René 'Necoro' Neumann6-74/+79 They should also use CRLF (cf issue #46). 2021-02-16Issue #46: Fix semantics of `n` resultRené 'Necoro' Neumann2-9/+15 Per contract, the returned number of bytes written should be the number of bytes _from the input_. Therefore, the added bytes (`\r` or `\n`) shall not count into that number. 2021-02-16Issue #46: Move and rename writer; add commentsRené 'Necoro' Neumann3-12/+21 2021-02-15Issue #46: Improvements; add testsRené 'Necoro' Neumann2-1/+48 2021-02-15Bump github.com/google/uuid from 1.1.4 to 1.2.0dependabot[bot]2-3/+3 Bumps [github.com/google/uuid](https://github.com/google/uuid) from 1.1.4 to 1.2.0. - [Release notes](https://github.com/google/uuid/releases) - [Commits](https://github.com/google/uuid/compare/v1.1.4...v1.2.0) Signed-off-by: dependabot[bot] <support@github.com> 2021-02-15Issue #46: Make the resulting email body not to include single \r or \n. ↵René 'Necoro' Neumann2-2/+66 This now pleases Cyrus IMAP. 2021-01-20Bump github.com/PuerkitoBio/goquery from 1.6.0 to 1.6.1dependabot[bot]2-3/+3 Bumps [github.com/PuerkitoBio/goquery](https://github.com/PuerkitoBio/goquery) from 1.6.0 to 1.6.1. - [Release notes](https://github.com/PuerkitoBio/goquery/releases) - [Commits](https://github.com/PuerkitoBio/goquery/compare/v1.6.0...v1.6.1) Signed-off-by: dependabot[bot] <support@github.com> 2021-01-09Bump github.com/google/uuid from 1.1.2 to 1.1.4dependabot[bot]2-3/+3 Bumps [github.com/google/uuid](https://github.com/google/uuid) from 1.1.2 to 1.1.4. - [Release notes](https://github.com/google/uuid/releases) - [Commits](https://github.com/google/uuid/compare/v1.1.2...v1.1.4) Signed-off-by: dependabot[bot] <support@github.com> 2021-01-09Bump github.com/emersion/go-message from 0.14.0 to 0.14.1 (#42)dependabot[bot]2-3/+3 Bumps [github.com/emersion/go-message](https://github.com/emersion/go-message) from 0.14.0 to 0.14.1. - [Release notes](https://github.com/emersion/go-message/releases) - [Commits](https://github.com/emersion/go-message/compare/v0.14.0...v0.14.1) Signed-off-by: dependabot[bot] <support@github.com> Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> 2020-11-28Bump github.com/emersion/go-message from 0.13.0 to 0.14.0 (#38)dependabot[bot]2-3/+9 Bumps [github.com/emersion/go-message](https://github.com/emersion/go-message) from 0.13.0 to 0.14.0. - [Release notes](https://github.com/emersion/go-message/releases) - [Commits](https://github.com/emersion/go-message/compare/v0.13.0...v0.14.0) Signed-off-by: dependabot[bot] <support@github.com> Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> 2020-11-28Bump github.com/google/go-cmp from 0.5.2 to 0.5.4 (#37)dependabot[bot]2-3/+3 Bumps [github.com/google/go-cmp](https://github.com/google/go-cmp) from 0.5.2 to 0.5.4. - [Release notes](https://github.com/google/go-cmp/releases) - [Commits](https://github.com/google/go-cmp/compare/v0.5.2...v0.5.4) Signed-off-by: dependabot[bot] <support@github.com> Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> 2020-11-23Fix release.ymlv0.5.2René 'Necoro' Neumann1-3/+10 2020-11-23Prepare v0.5.2René 'Necoro' Neumann3-3/+8 2020-11-20Bump github.com/gabriel-vasile/mimetype from 1.1.1 to 1.1.2dependabot[bot]2-3/+3 Bumps [github.com/gabriel-vasile/mimetype](https://github.com/gabriel-vasile/mimetype) from 1.1.1 to 1.1.2. - [Release notes](https://github.com/gabriel-vasile/mimetype/releases) - [Changelog](https://github.com/gabriel-vasile/mimetype/blob/master/CHANGELOG.md) - [Commits](https://github.com/gabriel-vasile/mimetype/compare/v1.1.1...v1.1.2) Signed-off-by: dependabot[bot] <support@github.com> 2020-11-04Clean dependabot.ymlRené 'Necoro' Neumann1-4/+0