diff options
author | René 'Necoro' Neumann <necoro@necoro.net> | 2010-05-11 17:54:33 +0200 |
---|---|---|
committer | René 'Necoro' Neumann <necoro@necoro.net> | 2010-05-11 17:54:33 +0200 |
commit | e87628fae9c1277e96be51fadb223b4605717437 (patch) | |
tree | 375f5b84c054780d10b216f949b1af0512e264d0 /setup.py | |
parent | 5fcdfa0c56c0bcaf3d1007eef644e627893f0923 (diff) | |
download | portato-e87628fae9c1277e96be51fadb223b4605717437.tar.gz portato-e87628fae9c1277e96be51fadb223b4605717437.tar.bz2 portato-e87628fae9c1277e96be51fadb223b4605717437.zip |
Improve setup.py for release script
Diffstat (limited to '')
-rw-r--r-- | setup.py | 11 |
1 files changed, 8 insertions, 3 deletions
@@ -42,17 +42,22 @@ data_files = [ cmdclass = {'build_manpage': build_manpage} # remove useless options / they are the default -for o in ("cython", "eix"): +for o in ( + "eix", + "cython", #!REMOVE + ): try: sys.argv.remove("--enable-"+o) except ValueError: pass # extension stuff -if "--disable-cython" in sys.argv: - sys.argv.remove("--disable-cython") +#!INSERT if not "--enable-cython" in sys.argv: +if "--disable-cython" in sys.argv: #!REMOVE + sys.argv.remove("--disable-cython") #!REMOVE ext = "c" else: + #!INSERT sys.argv.remove("--enable-cython") from Cython.Distutils import build_ext cmdclass['build_ext'] = build_ext ext = "pyx" |