diff options
author | necoro <> | 2007-01-24 22:15:27 +0000 |
---|---|---|
committer | necoro <> | 2007-01-24 22:15:27 +0000 |
commit | 3a1d0db1f30133bae568341428d427cf5a5d0495 (patch) | |
tree | f9d77762827ab71dea40d9d78513806da1fcc7fc /setup.py | |
parent | c7e0ba131ab7169573dc0278f4ea3b19c13e9e26 (diff) | |
download | portato-3a1d0db1f30133bae568341428d427cf5a5d0495.tar.gz portato-3a1d0db1f30133bae568341428d427cf5a5d0495.tar.bz2 portato-3a1d0db1f30133bae568341428d427cf5a5d0495.zip |
- Added icons
- Added support for killing the process
- Reorganised setup and starting-script
Diffstat (limited to '')
-rw-r--r-- | setup.py | 25 |
1 files changed, 18 insertions, 7 deletions
@@ -2,13 +2,24 @@ # -*- coding: utf-8 -*- from distutils.core import setup, Extension -from portato.constants import VERSION, DATA_DIR +from portato.constants import VERSION, DATA_DIR, FRONTENDS + +packages = ["portato", "portato.gui", "portato.backend"] +ext_modules = [] +data_files = [] +cmdclass = {} + +if "gtk" in FRONTENDS: + packages.append("portato.gui.gtk") + data_files.append((DATA_DIR, ["portato/gui/gtk/glade/portato.glade"])) setup(name="Portato", - version=VERSION, - author="René 'Necoro' Neumann", - license="GPLv2", - author_email="necoro@necoro.net", - packages=["portato", "portato.gui", "portato.backend", "portato.gui.gtk"], - data_files=[(DATA_DIR, ["portato/gui/gtk/glade/portato.glade"])] + version = VERSION, + author = "René 'Necoro' Neumann", + license = "GPLv2", + author_email = "necoro@necoro.net", + packages = packages, + data_files = data_files, + ext_modules = ext_modules, + cmdclass = cmdclass ) |