summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2008-03-18 20:02:53 +0100
committerRené 'Necoro' Neumann <necoro@necoro.net>2008-03-18 20:02:53 +0100
commit57c377c2ea2d8f2b3c265a2f54925fd661ac3164 (patch)
tree1aa2b4650cad1516ce10680b882e2a3cfb06d42d /setup.py
parent1024a00138be442884acbdc3ed6faf28e03ad69b (diff)
downloadportato-57c377c2ea2d8f2b3c265a2f54925fd661ac3164.tar.gz
portato-57c377c2ea2d8f2b3c265a2f54925fd661ac3164.tar.bz2
portato-57c377c2ea2d8f2b3c265a2f54925fd661ac3164.zip
Removed gtk subdir
Diffstat (limited to '')
-rw-r--r--setup.py14
1 files changed, 6 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index c595cd9..c8fe3e6 100644
--- a/setup.py
+++ b/setup.py
@@ -13,7 +13,7 @@
import sys, os, os.path
from distutils.core import setup, Extension
-from portato.constants import FRONTENDS, VERSION, DATA_DIR, ICON_DIR, PLUGIN_DIR, TEMPLATE_DIR
+from portato.constants import VERSION, DATA_DIR, ICON_DIR, PLUGIN_DIR, TEMPLATE_DIR
### copied from shm's setup.py ###
@@ -122,23 +122,21 @@ def plugin_list (*args):
"""Creates a list of correct plugin pathes out of the arguments."""
return [("plugins/%s.xml" % x) for x in args]
-packages = ["portato", "portato.gui", "portato.plugins", "portato.backend", "portato.backend.portage", "portato.backend.catapult", "portato._shm"]
+packages = ["portato", "portato.gui", "portato.gui.windows", "portato.plugins", "portato.backend", "portato.backend.portage", "portato.backend.catapult", "portato._shm"]
ext_modules = [Extension("portato._shm.shm", ["_shm/shmmodule.c"], define_macros = MacrosAndDefines, extra_compile_args=["-fPIC"])]
data_files = [
- (ICON_DIR, ["icons/portato-icon.png"]),
+ (TEMPLATE_DIR, [os.path.join("portato/gui/templates",x) for x in os.listdir("portato/gui/templates") if x.endswith(".glade")]),
+ (ICON_DIR, ["icons/portato-icon.png"]),
#(PLUGIN_DIR, plugin_list("shutdown", "resume_loop")),
(DATA_DIR, ["plugin.xsd"])]
+
cmdclass = {}
package_dir = {"portato._shm" : "_shm"}
-if "gtk" in FRONTENDS:
- packages.append("portato.gui.gtk")
- data_files.append((TEMPLATE_DIR, [os.path.join("portato/gui/templates",x) for x in os.listdir("portato/gui/templates") if x.endswith(".glade")]))
-
# do the distutils setup
setup(name="Portato",
version = VERSION,
- description = "Frontends to Portage",
+ description = "GTK-Frontend to Portage",
license = "GPLv2",
url = "http://portato.origo.ethz.ch/",
author = "René 'Necoro' Neumann",
+0000'>2008-01-14 r617@Devoty: necoro | 2008-01-14 19:12:59 +0100Necoro2-10/+10 2008-01-14 r609@Devoty: necoro | 2008-01-14 17:04:38 +0100Necoro9-394/+477 2008-01-14 r605@Devoty: necoro | 2008-01-14 11:43:34 +0100Necoro2-26/+129 2008-01-14 r603@Devoty: necoro | 2008-01-14 11:30:26 +0100Necoro4-26/+38 2008-01-11 r598@Devoty: necoro | 2008-01-10 16:36:29 +0100Necoro4-10/+50 2008-01-11 r597@Devoty: necoro | 2008-01-10 14:12:35 +0100Necoro1-3/+3 2008-01-10 r595@Devoty: necoro | 2008-01-10 04:04:15 +0100Necoro1-52/+3 2008-01-09 r586@Devoty: necoro | 2008-01-09 14:54:18 +0100Necoro1-1/+1 2007-12-06 r577@Devoty: necoro | 2007-12-06 20:37:36 +0100Necoro1-1/+1 2007-12-06 r572@Devoty: necoro | 2007-11-28 08:48:15 +0100Necoro1-0/+1 2007-11-27 r570@Devoty: necoro | 2007-11-27 02:08:21 +0100Necoro3-84/+108