diff options
author | René 'Necoro' Neumann <necoro@necoro.net> | 2009-03-24 20:05:54 +0100 |
---|---|---|
committer | René 'Necoro' Neumann <necoro@necoro.net> | 2009-03-24 20:05:54 +0100 |
commit | e3c683f84345051612f670d2faade7ef638b406a (patch) | |
tree | 841e8115fbdc97b601044a4bfaed87bfc270ab0b /setup.py | |
parent | 9803bc511d8737703985fb00dddcafa7a687c574 (diff) | |
download | portato-e3c683f84345051612f670d2faade7ef638b406a.tar.gz portato-e3c683f84345051612f670d2faade7ef638b406a.tar.bz2 portato-e3c683f84345051612f670d2faade7ef638b406a.zip |
Added build_manpage support. Moved all the startup logic from portato.py to portato/__init__.py
Diffstat (limited to '')
-rw-r--r-- | setup.py | 5 |
1 files changed, 4 insertions, 1 deletions
@@ -15,6 +15,8 @@ import sys, os, os.path from distutils.core import setup from portato.constants import VERSION, DATA_DIR, ICON_DIR, PLUGIN_DIR, TEMPLATE_DIR +from build_manpage import build_manpage + def plugin_list (*args): """Creates a list of correct plugin pathes out of the arguments.""" return [("plugins/%s.py" % x) for x in args] @@ -34,5 +36,6 @@ setup(name="Portato", author = "René 'Necoro' Neumann", author_email = "necoro@necoro.net", packages = packages, - data_files = data_files + data_files = data_files, + cmdclass={'build_manpage': build_manpage} ) |