summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authornecoro <>2007-04-24 15:34:07 +0000
committernecoro <>2007-04-24 15:34:07 +0000
commite8868d63c39db975c8627c7fc87dfdd4f2308bf6 (patch)
tree801a6c1ab0d7d899007e39a4c0d7720bd37c9b15 /setup.py
parent5067dac60487edc83ac88c18b9b880eb7ccd5259 (diff)
downloadportato-e8868d63c39db975c8627c7fc87dfdd4f2308bf6.tar.gz
portato-e8868d63c39db975c8627c7fc87dfdd4f2308bf6.tar.bz2
portato-e8868d63c39db975c8627c7fc87dfdd4f2308bf6.zip
moved *.glade and *.ui to one directory to omit the change of the config.py each time
Diffstat (limited to '')
-rw-r--r--setup.py8
1 files changed, 5 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 8fe3bb0..2e294fc 100644
--- a/setup.py
+++ b/setup.py
@@ -12,16 +12,18 @@ cmdclass = {}
if "gtk" in FRONTENDS:
packages.append("portato.gui.gtk")
- data_files.append((DATA_DIR, ["portato/gui/gtk/glade/portato.glade"]))
+ data_files.append((DATA_DIR, ["portato/gui/templates/portato.glade"]))
if "qt" in FRONTENDS:
packages.append("portato.gui.qt")
- data_files.append((os.path.join(DATA_DIR,"ui"), [os.path.join("portato/gui/qt/ui",x) for x in os.listdir("portato/gui/qt/ui/") if x.endswith(".ui")]))
+ data_files.append((os.path.join(DATA_DIR,"ui"), [os.path.join("portato/gui/templates/ui",x) for x in os.listdir("portato/gui/templates/ui/") if x.endswith(".ui")]))
setup(name="Portato",
version = VERSION,
- author = "René 'Necoro' Neumann",
+ description = "Frontends to Portage",
license = "GPLv2",
+ url = "http://portato.sourceforge.net/",
+ author = "René 'Necoro' Neumann",
author_email = "necoro@necoro.net",
packages = packages,
data_files = data_files,
pan class='deletions'>-33/+130 2007-05-13Add max-commit-count parameter to cgitrcLars Hjemli4-2/+10 2007-05-13Show number of changed lines in log viewLars Hjemli1-1/+11 2007-05-13Simplify ui-diff.c using the new file-level diff interfaceLars Hjemli1-86/+2 2007-05-13Add standard interface for file diff functionsLars Hjemli2-0/+86 2007-05-13Show number of changed files in log viewLars Hjemli1-2/+15 2007-05-13Use standard tree-diff function when showing diffstat for single commitLars Hjemli1-51/+15 2007-05-13Add shared diff-handling functionsLars Hjemli2-2/+50 2007-05-12css: fix bad rendering in Internet ExplorerLars Hjemli1-2/+7 2007-05-11Add links to enable downloading of tagged blobsLars Hjemli2-9/+85 2007-05-11Makefile: add support for building w.o. preinstalled gitLars Hjemli1-1/+13 2007-05-11Tag release v0.3v0.3Lars Hjemli1-1/+1 2007-05-11Update README with submodule build infoLars Hjemli1-13/+39 2007-05-11Add submodule links in tree listingLars Hjemli6-12/+27 2007-05-11Add submodules.sh and use it during buildsLars Hjemli3-13/+222 2007-05-11Added git as a submoduleLars Hjemli2-1/+1 2007-05-09Add support for downloading single blobsLars Hjemli5-3/+47 2007-05-08ui-view: show pathname if specified in querystringLars Hjemli3-5/+10 2007-05-08Update to libgit 1.5.2-rc2Lars Hjemli9-837/+50 2007-02-21Layout updateLars Hjemli9-32/+127 2007-02-08Make snapshot feature configurableLars Hjemli5-6/+22 2007-02-08Add support for snapshotsLars Hjemli8-8/+153 2007-02-05cgit v0.2v0.2Lars Hjemli1-1/+1 2007-02-05Add support for prefix and gitsrc arguments to 'make'Lars Hjemli2-15/+37 2007-02-04Update cgitrc templateLars Hjemli1-21/+32 2007-02-04Add support for lightweight tagsLars Hjemli2-19/+37 2007-02-04Read repo-info from /etc/cgitrcLars Hjemli5-55/+120 2007-02-04Do not die if tag has no messageLars Hjemli1-2/+2 2007-02-03Fix search for non-virtual urlsLars Hjemli1-0/+6 2007-01-28Update README with install/config informationLars Hjemli1-24/+28