diff options
author | René 'Necoro' Neumann <necoro@necoro.net> | 2009-08-15 12:10:15 +0200 |
---|---|---|
committer | René 'Necoro' Neumann <necoro@necoro.net> | 2009-08-15 12:10:15 +0200 |
commit | 62c7271dc0fbb348be83304a2ffd823cb21c10d7 (patch) | |
tree | b31e18e3e08ab7492e4af2fd16904faa10c952f6 /setup.py | |
parent | 1e59217d2b2266b4870a51667ad71b011aa4204f (diff) | |
parent | 2fdd70e3a102f666ab9f036d76e7e892421f6840 (diff) | |
download | portato-62c7271dc0fbb348be83304a2ffd823cb21c10d7.tar.gz portato-62c7271dc0fbb348be83304a2ffd823cb21c10d7.tar.bz2 portato-62c7271dc0fbb348be83304a2ffd823cb21c10d7.zip |
Merge in own message queue module
Diffstat (limited to '')
-rw-r--r-- | setup.py | 11 |
1 files changed, 4 insertions, 7 deletions
@@ -15,6 +15,8 @@ import os import sys from distutils.core import setup +from distutils.extension import Extension +from Cython.Distutils import build_ext from portato.constants import VERSION, ICON_DIR, PLUGIN_DIR, TEMPLATE_DIR, APP @@ -38,17 +40,12 @@ data_files = [ (PLUGIN_DIR, plugin_list("gpytage", "notify", "etc_proposals", "reload_portage", "package_details"))] # extension stuff -ext_modules = [] -cmdclass={'build_manpage': build_manpage} +ext_modules = [Extension("portato.ipc", ["portato/ipc.pyx"])] if "--disable-eix" in sys.argv: sys.argv.remove("--disable-eix") else: - from Cython.Distutils import build_ext - from distutils.extension import Extension - ext_modules.append(Extension("portato.eix.parser", ["portato/eix/parser.pyx"])) - cmdclass['build_ext'] = build_ext packages.append("portato.eix") if "--enable-eix" in sys.argv: @@ -67,5 +64,5 @@ setup(name=APP, packages = packages, data_files = data_files, ext_modules = ext_modules, - cmdclass = cmdclass + cmdclass={'build_manpage': build_manpage, 'build_ext' : build_ext} ) |