diff options
author | necoro <> | 2007-07-07 02:27:31 +0000 |
---|---|---|
committer | necoro <> | 2007-07-07 02:27:31 +0000 |
commit | 91225d6ff5bc70cd76d0cf54f35a1cf6186b538b (patch) | |
tree | cd6514fdf518f4d54beafbbb64fefd8bcbc16bd5 /setup.py | |
parent | d1b6cf6e24b3f2ca310a07313a162bc8f790679f (diff) | |
download | portato-91225d6ff5bc70cd76d0cf54f35a1cf6186b538b.tar.gz portato-91225d6ff5bc70cd76d0cf54f35a1cf6186b538b.tar.bz2 portato-91225d6ff5bc70cd76d0cf54f35a1cf6186b538b.zip |
Some documentation work
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 19 |
1 files changed, 18 insertions, 1 deletions
@@ -1,13 +1,29 @@ #!/usr/bin/python # -*- coding: utf-8 -*- +# +# File: setup.py +# This file is part of the Portato-Project, a graphical portage-frontend. +# +# Copyright (C) 2006-2007 René 'Necoro' Neumann +# This is free software. You may redistribute copies of it under the terms of +# the GNU General Public License version 2. +# There is NO WARRANTY, to the extent permitted by law. +# +# Written by René 'Necoro' Neumann <necoro@necoro.net> import os, os.path from distutils.core import setup, Extension from portato.constants import VERSION, DATA_DIR, FRONTENDS, ICON_DIR, PLUGIN_DIR def plugin_list (*args): + """Creates a list of correct plugin pathes out of the arguments.""" return [("plugins/%s.xml" % x) for x in args] +def ui_file_list (): + """Returns the list of *.ui-files.""" + uis = [x for x in os.listdir("portato/gui/templates/ui/") if x.endswith(".ui")] + return [os.path.join("portato/gui/templates/ui",x) for x in uis] + packages = ["portato", "portato.gui", "portato.plugins", "portato.backend", "portato.backend.portage"] ext_modules = [] data_files = [(ICON_DIR, ["icons/portato-icon.png"]), (PLUGIN_DIR, plugin_list("shutdown"))] @@ -19,8 +35,9 @@ if "gtk" in FRONTENDS: if "qt" in FRONTENDS: packages.append("portato.gui.qt") - data_files.append((os.path.join(DATA_DIR,"ui"), [os.path.join("portato/gui/templates/ui",x) for x in os.listdir("portato/gui/templates/ui/") if x.endswith(".ui")])) + data_files.append((os.path.join(DATA_DIR,"ui"), ui_file_list())) +# do the distutils setup setup(name="Portato", version = VERSION, description = "Frontends to Portage", |