diff options
author | necoro <> | 2007-07-20 07:19:27 +0000 |
---|---|---|
committer | necoro <> | 2007-07-20 07:19:27 +0000 |
commit | d1a5c99708fa5e2fc0387e31ccb57f004d74f2fc (patch) | |
tree | 0441e1cec9d2881f939a017ba3e9ba2da9a2797e /setup.py | |
parent | 0a8d3b8add548efbc44a67c3eb1223ff94aaffc5 (diff) | |
download | portato-d1a5c99708fa5e2fc0387e31ccb57f004d74f2fc.tar.gz portato-d1a5c99708fa5e2fc0387e31ccb57f004d74f2fc.tar.bz2 portato-d1a5c99708fa5e2fc0387e31ccb57f004d74f2fc.zip |
new Plugin Scheme
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -13,7 +13,7 @@ import os, os.path from distutils.core import setup, Extension -from portato.constants import VERSION, DATA_DIR, FRONTENDS, ICON_DIR, PLUGIN_DIR +from portato.constants import VERSION, DATA_DIR, FRONTENDS, ICON_DIR, PLUGIN_DIR, XSD_DIR def plugin_list (*args): """Creates a list of correct plugin pathes out of the arguments.""" @@ -26,7 +26,7 @@ def ui_file_list (): packages = ["portato", "portato.gui", "portato.plugins", "portato.backend", "portato.backend.portage"] ext_modules = [] -data_files = [(ICON_DIR, ["icons/portato-icon.png"]), (PLUGIN_DIR, plugin_list("shutdown", "resume_loop"))] +data_files = [(ICON_DIR, ["icons/portato-icon.png"]), (PLUGIN_DIR, plugin_list("shutdown", "resume_loop")), (XSD_DIR, ["plugin.xsd"])] cmdclass = {} if "gtk" in FRONTENDS: |