summaryrefslogtreecommitdiff
path: root/portato/backend/portage_helper.py
diff options
context:
space:
mode:
Diffstat (limited to 'portato/backend/portage_helper.py')
-rw-r--r--portato/backend/portage_helper.py24
1 files changed, 12 insertions, 12 deletions
diff --git a/portato/backend/portage_helper.py b/portato/backend/portage_helper.py
index 1726323..814a0bb 100644
--- a/portato/backend/portage_helper.py
+++ b/portato/backend/portage_helper.py
@@ -78,22 +78,22 @@ def find_packages (search_key, masked=False):
try:
if masked:
- t = portage.db["/"]["porttree"].dbapi.xmatch("match-all", search_key)
- t += portage.db["/"]["vartree"].dbapi.match(search_key)
+ t = porttree.dbapi.xmatch("match-all", search_key)
+ t += vartree.dbapi.match(search_key)
else:
- t = portage.db["/"]["porttree"].dbapi.match(search_key)
- t += portage.db["/"]["vartree"].dbapi.match(search_key)
- # catch the "amgigous package" Exception
+ t = porttree.dbapi.match(search_key)
+ t += vartree.dbapi.match(search_key)
+ # catch the "ambigous package" Exception
except ValueError, e:
if type(e[0]) == types.ListType:
t = []
for cp in e[0]:
if masked:
- t += portage.db["/"]["porttree"].dbapi.xmatch("match-all", cp)
- t += portage.db["/"]["vartree"].dbapi.match(cp)
+ t += porttree.dbapi.xmatch("match-all", cp)
+ t += vartree.dbapi.match(cp)
else:
- t += portage.db["/"]["porttree"].dbapi.match(cp)
- t += portage.db["/"]["vartree"].dbapi.match(cp)
+ t += porttree.dbapi.match(cp)
+ t += vartree.dbapi.match(cp)
else:
raise ValueError(e)
# Make the list of packages unique
@@ -113,13 +113,13 @@ def find_installed_packages (search_key, masked=False):
@rtype: backend.Package[]"""
try:
- t = portage.db["/"]["vartree"].dbapi.match(search_key)
- # catch the "amgigous package" Exception
+ t = vartree.dbapi.match(search_key)
+ # catch the "ambigous package" Exception
except ValueError, e:
if type(e[0]) == types.ListType:
t = []
for cp in e[0]:
- t += portage.db["/"]["vartree"].dbapi.match(cp)
+ t += vartree.dbapi.match(cp)
else:
raise ValueError(e)
'2008-07-08 14:58:20 +0200'>2008-07-08Removed catapultRené 'Necoro' Neumann3-427/+0 2008-07-08Added the reload_portage pluginRené 'Necoro' Neumann1-1/+1 2008-07-08Added the reload_portage pluginRené 'Necoro' Neumann2-4/+36 2008-07-08Very basic documentationRené 'Necoro' Neumann1-57/+16 2008-07-08Documented the plugin moduleRené 'Necoro' Neumann2-32/+229 2008-07-04Ported remaining pluginsRené 'Necoro' Neumann6-89/+100 2008-07-04Removed lxml version in error stringRené 'Necoro' Neumann1-2/+1 2008-07-04Removed lxml version in error stringRené 'Necoro' Neumann1-3/+1 2008-07-04Ignore errors on plugin loadingRené 'Necoro' Neumann1-0/+6 2008-07-04Added ability to install missing plugin depsRené 'Necoro' Neumann3-95/+126 2008-07-04Fixed find_best_match for <portage-2.1.5René 'Necoro' Neumann1-2/+2 2008-07-04Some more dependency awarenessRené 'Necoro' Neumann5-23/+59 2008-07-03Some window refinementRené 'Necoro' Neumann1-109/+126 2008-07-03Removed XSD_LOCATION -- as there is no more xsd ;)René 'Necoro' Neumann2-5/+1 2008-07-03Updated setup.py to install the correct set of pluginsRené 'Necoro' Neumann1-3/+2 2008-07-03Ported etc-proposals pluginRené 'Necoro' Neumann3-50/+43 2008-07-03Ported gpytage pluginRené 'Necoro' Neumann2-16/+14 2008-07-03Ported Notify pluginRené 'Necoro' Neumann4-37/+51 2008-07-03Remove xsd and -x cmdline optionRené 'Necoro' Neumann2-107/+1 2008-07-03Ported completelyRené 'Necoro' Neumann3-548/+54 2008-07-03Should show dependencies nowRené 'Necoro' Neumann2-82/+128 2008-07-03Use __slots__ for the PkgData class to save memoryRené 'Necoro' Neumann1-2/+3 2008-07-03New plugin system - first hackRené 'Necoro' Neumann2-420/+683 2008-06-30Now the new design is able to do the same as the old oneRené 'Necoro' Neumann3-168/+182 2008-06-30First draft of the new plugin windowRené 'Necoro' Neumann1-8/+172 2008-06-30Added stuff to plugin.pyRené 'Necoro' Neumann1-2/+24 2008-06-30Beautified some dialogsRené 'Necoro' Neumann1-6/+8 2008-06-30Only add a package to mergequeue if everything went fineRené 'Necoro' Neumann1-1/+1 2008-06-26Removed '__find_resolved_unresolved' as it is quite useless.René 'Necoro' Neumann3-53/+29 2008-06-26Added very basic set queryingRené 'Necoro' Neumann3-0/+27 2008-06-25Now load 22 versions when running the correct portageRené 'Necoro' Neumann4-8/+18 2008-06-25Added Package_22 and System_22René 'Necoro' Neumann4-5/+63