diff options
Diffstat (limited to '')
-rw-r--r-- | setup.py | 25 |
1 files changed, 18 insertions, 7 deletions
@@ -2,13 +2,24 @@ # -*- coding: utf-8 -*- from distutils.core import setup, Extension -from portato.constants import VERSION, DATA_DIR +from portato.constants import VERSION, DATA_DIR, FRONTENDS + +packages = ["portato", "portato.gui", "portato.backend"] +ext_modules = [] +data_files = [] +cmdclass = {} + +if "gtk" in FRONTENDS: + packages.append("portato.gui.gtk") + data_files.append((DATA_DIR, ["portato/gui/gtk/glade/portato.glade"])) setup(name="Portato", - version=VERSION, - author="René 'Necoro' Neumann", - license="GPLv2", - author_email="necoro@necoro.net", - packages=["portato", "portato.gui", "portato.backend", "portato.gui.gtk"], - data_files=[(DATA_DIR, ["portato/gui/gtk/glade/portato.glade"])] + version = VERSION, + author = "René 'Necoro' Neumann", + license = "GPLv2", + author_email = "necoro@necoro.net", + packages = packages, + data_files = data_files, + ext_modules = ext_modules, + cmdclass = cmdclass ) |