summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--setup.py7
1 files changed, 3 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 26796a7..80d4eb5 100644
--- a/setup.py
+++ b/setup.py
@@ -2,14 +2,13 @@
# -*- coding: utf-8 -*-
from distutils.core import setup, Extension
-
-#thread = Extension("geneticone.modules.geneticthread", sources=["geneticone/modules/geneticthread.c"])
+from geneticone.constants import VERSION, DATA_DIR
setup(name="Genetic/One",
- version="SVN",
+ version=VERSION,
author="René 'Necoro' Neumann",
license="GPLv2",
author_email="necoro@necoro.net",
packages=["geneticone", "geneticone.gui", "geneticone.backend", "geneticone.gui.gtk"],
- #ext_modules=[thread]
+ data_files={DATA_DIR: ["geneticone/gui/gtk/glade/geneticone.glade"]}
)
ref='/portato.git/commit/geneticone/gui/gui_helper.py?h=0.13&id=0e5d5476cf83af44597d20da1889f429e622c0ca&follow=1'>Made newuse workingnecoro4-15/+30 2006-10-27Added wrapper for Tree and Consolenecoro6-17/+234 2006-10-27added encodingnecoro1-0/+1 2006-10-27Moved gtk-specific stuff to an extra subdir to make it more flexible for qtnecoro8-46/+67 2006-10-26Changed all occurences of "Necoro d.M." into "René 'Necoro' Neumann"necoro14-29/+29 2006-10-21Bug -.-necoro1-1/+1 2006-10-210.4.5necoro1-1/+1 2006-10-21no newuse flag atmnecoro1-2/+2 2006-10-21nomsgnecoro3-17/+32 2006-10-18fixed bug in update_world which ignored systemnecoro3-3/+28 2006-10-16Introduced watch_cursor decoratornecoro2-21/+31 2006-10-16Speedup for "--deep"; loading sign for update world; handling packages not in...necoro5-18/+67 2006-10-15Changed confignecoro1-4/+4 2006-10-15Second level of "emerge --update"necoro5-15/+120 2006-10-15Implemented emerge --syncnecoro2-0/+10 2006-10-15First implementation of "emerge --update world"necoro4-17/+100 2006-10-14Wah - I'm tired ...necoro1-3/+3 2006-10-14and now another bug -.-necoro1-2/+2 2006-10-14forgot one returnnecoro1-0/+2 2006-10-14Set min height to 600 if maxHeight is smaller then 800necoro2-4/+7 2006-10-13Some more documentationnecoro2-82/+298 2006-10-13Documentation worknecoro2-154/+160 2006-10-12Enabled oneshotnecoro3-32/+103 2006-10-12Layout updatenecoro1-16/+38 2006-10-12Fixed bugsnecoro2-15/+16 2006-10-12Migrated to UIManagernecoro1-33/+64 2006-10-10Fixed bug not showing the use-flag-list in some casesnecoro1-3/+5 2006-10-09bla - prepared 0.4.0 ; added dialogs.py; extended some commentsnecoro9-125/+293 2006-10-08Made the testing stuff working too ... I hope ^^ ... removed obsolete-dirnecoro7-145/+113 2006-10-05Added first support for the masking stuff ... and hoping that it is going to ...necoro5-79/+135 2006-10-05Changed changelog / added config-filenecoro2-0/+10 2006-10-05Added preference windownecoro4-49/+155 2006-10-02Corrected comments, structure, bad algorithms etcnecoro4-176/+209 2006-10-02Corrected indention in commentnecoro1-8/+6 2006-10-010.3.3necoro1-0/+6 2006-10-01Implemented an internal db; removed unmerge-bugnecoro2-26/+43 2006-09-30Implemented some new backend functions which speed up the package-list-creati...necoro2-12/+37 2006-09-300.3.2 release; changed font in terminal; added new "masking"-dialognecoro3-11/+36 2006-09-29fixed bugsnecoro4-13/+23 2006-09-29Corrected setup.pynecoro1-1/+1