summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index af82b7f..8fe3bb0 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,7 @@
#!/usr/bin/python
# -*- coding: utf-8 -*-
+import os, os.path
from distutils.core import setup, Extension
from portato.constants import VERSION, DATA_DIR, FRONTENDS
@@ -13,6 +14,10 @@ if "gtk" in FRONTENDS:
packages.append("portato.gui.gtk")
data_files.append((DATA_DIR, ["portato/gui/gtk/glade/portato.glade"]))
+if "qt" in FRONTENDS:
+ packages.append("portato.gui.qt")
+ data_files.append((os.path.join(DATA_DIR,"ui"), [os.path.join("portato/gui/qt/ui",x) for x in os.listdir("portato/gui/qt/ui/") if x.endswith(".ui")]))
+
setup(name="Portato",
version = VERSION,
author = "René 'Necoro' Neumann",