summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.eu>2020-11-25 00:18:40 +0100
committerRené 'Necoro' Neumann <necoro@necoro.eu>2020-11-25 00:30:26 +0100
commit3a2cce3daebc0d2e0705fa2ee363eb502ce1cbd3 (patch)
treef907e3ceeb0780062e009350bb27d687f6ba5e6f /PKGBUILD
parent62a09d625b507b49a3d119448895ff7512de78e5 (diff)
downloadmasterpdfeditor-master.tar.gz
masterpdfeditor-master.tar.bz2
masterpdfeditor-master.zip
Include removed .desktop fileHEADmaster
Diffstat (limited to '')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5e95e93..503a793 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,10 @@ url='https://code-industry.net/free-pdf-editor/'
arch=('x86_64')
license=('custom')
makedepends=('patchelf')
-source_x86_64=("https://code-industry.net/public/master-pdf-editor-${pkgver}-qt5.x86_64.tar.gz")
-sha1sums_x86_64=('0225cccbda7a3d0b7a6041c64cbda6f997d3095d')
+source_x86_64=("https://code-industry.net/public/master-pdf-editor-${pkgver}-qt5.x86_64.tar.gz"
+ masterpdfeditor5.desktop)
+sha1sums_x86_64=('0225cccbda7a3d0b7a6041c64cbda6f997d3095d'
+ 'b33e7148123565fd4cc15d41c493f6ab27d37ba4')
package() {
depends=('libgl' 'nspr' 'nss' 'qt5-base' 'qt5-svg' 'sane')
@@ -23,7 +25,7 @@ package() {
cd "$pkgdir/opt/master-pdf-editor-${pkgver%%.*}"
ln -sr masterpdfeditor${pkgver%%.*} -t "$pkgdir/usr/bin/"
- install -Dm644 masterpdfeditor${pkgver%%.*}.desktop -t "$pkgdir/usr/share/applications/"
+ install -Dm644 ${srcdir}/masterpdfeditor${pkgver%%.*}.desktop -t "$pkgdir/usr/share/applications/"
install -Dm644 license.txt -t "$pkgdir/usr/share/licenses/$pkgname/"
patchelf --remove-rpath masterpdfeditor${pkgver%%.*}
}