summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.eu>2022-09-23 00:28:50 +0200
committerRené 'Necoro' Neumann <necoro@necoro.eu>2022-09-23 00:28:50 +0200
commit27ca0dd02907c6c1e14f3857672553c4ab2d5eac (patch)
tree8f719602aa94b8f1ad698a79bee519df862bdb72
parentc406274856414808521098fe1c185b528cac4300 (diff)
downloadsieve-app-bin-27ca0dd02907c6c1e14f3857672553c4ab2d5eac.tar.gz
sieve-app-bin-27ca0dd02907c6c1e14f3857672553c4ab2d5eac.tar.bz2
sieve-app-bin-27ca0dd02907c6c1e14f3857672553c4ab2d5eac.zip
Remove unwritten dep on unzip
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c84594..1b72bec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,15 +9,20 @@ arch=('x86_64')
url="https://github.com/thsmi/sieve/"
license=('AGPL-3.0')
-source=("https://github.com/thsmi/sieve/releases/download/${pkgver}/sieve-${pkgver}-linux-x64.zip"
+_zip="sieve-${pkgver}-linux-x64.zip"
+source=("https://github.com/thsmi/sieve/releases/download/${pkgver}/${_zip}"
"${_appname}.desktop")
sha256sums=('8b146c4681d6395c146d20e6337db6ad58d098bf6621b7c79d48cc81d7c82abe'
'cdd12628fcd3ff6d23cbb746e6cbdacc441fc93ed223796ef6db144b152f14a1')
-noextract=("sieve-${pkgver}-linux-x64.zip")
package() {
install -d -m0755 "${pkgdir}/"{opt/"${_appname}",usr/bin}
- unzip -d "${pkgdir}/opt/${_appname}" "sieve-${pkgver}-linux-x64.zip"
+
+ # the contents of the source file are extracted directly at the top level...
+ # thus, remove the zip so we can install the rest
+ rm "${_zip}"
+ cp -a --no-preserve=ownership * "${pkgdir}/opt/${_appname}"
+
chmod -R o+rX "${pkgdir}/opt/${_appname}"
ln -s "/opt/${_appname}/sieve" "${pkgdir}/usr/bin/sieve"
install -D -m0644 "${_appname}.desktop" "${pkgdir}/usr/share/applications/${_appname}.desktop"