summaryrefslogtreecommitdiff
path: root/app-office/radicale/radicale-0.3.ebuild
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2010-08-03 23:56:09 +0200
committerRené 'Necoro' Neumann <necoro@necoro.net>2010-08-03 23:56:09 +0200
commit435e36b905e09d66218e19ce60702e071fc66397 (patch)
tree7f8ec8875d1a2cf22e09d999bd3e07dd640a77a6 /app-office/radicale/radicale-0.3.ebuild
parentf91962a5a46e683e2276c5b56fc768cb32e70b9a (diff)
downloadoverlay-435e36b905e09d66218e19ce60702e071fc66397.tar.gz
overlay-435e36b905e09d66218e19ce60702e071fc66397.tar.bz2
overlay-435e36b905e09d66218e19ce60702e071fc66397.zip
Removed revision
Diffstat (limited to 'app-office/radicale/radicale-0.3.ebuild')
-rw-r--r--app-office/radicale/radicale-0.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-office/radicale/radicale-0.3.ebuild b/app-office/radicale/radicale-0.3.ebuild
new file mode 100644
index 0000000..3e2a99e
--- /dev/null
+++ b/app-office/radicale/radicale-0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+PYTHON_DEPEND="*:2.5"
+SUPPORT_PYTHON_ABIS=1
+
+inherit eutils distutils
+
+MY_P="${PN/r/R}-${PV}"
+
+DESCRIPTION="A simple CalDAV calendar server"
+HOMEPAGE="http://www.radicale.org/"
+SRC_URI="http://www.radicale.org/src/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ distutils_src_prepare
+
+ epatch ${FILESDIR}/radicale-0.3-foreground.patch
+}
+
+src_install() {
+ distutils_src_install
+
+ newinitd ${FILESDIR}/radicale.init.d radicale
+}
+
+pkg_postinst() {
+ elog "If you want to use SSL with ${PN}, please check that you have"
+ elog "installed >=dev-lang/python-2.6[ssl]."
+}