summaryrefslogtreecommitdiff
path: root/app-office/radicale/radicale-0.6.ebuild
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2011-08-09 00:29:17 +0200
committerRené 'Necoro' Neumann <necoro@necoro.net>2011-08-09 00:29:45 +0200
commit5793fe6e26d1a6785e6a0a130cb3ba589da9ca23 (patch)
treee126ab1609b3dccb9dbbd72f1e38dd6990beeae3 /app-office/radicale/radicale-0.6.ebuild
parent11aafbb7bb36ac1a6573f6e2756b4dadd5ffc353 (diff)
downloadoverlay-5793fe6e26d1a6785e6a0a130cb3ba589da9ca23.tar.gz
overlay-5793fe6e26d1a6785e6a0a130cb3ba589da9ca23.tar.bz2
overlay-5793fe6e26d1a6785e6a0a130cb3ba589da9ca23.zip
Radicale
Diffstat (limited to 'app-office/radicale/radicale-0.6.ebuild')
-rw-r--r--app-office/radicale/radicale-0.6.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/app-office/radicale/radicale-0.6.ebuild b/app-office/radicale/radicale-0.6.ebuild
index cb5ed97..5ad083c 100644
--- a/app-office/radicale/radicale-0.6.ebuild
+++ b/app-office/radicale/radicale-0.6.ebuild
@@ -3,7 +3,7 @@
# $Header: $
EAPI=2
-PYTHON_DEPEND="*:2.5"
+PYTHON_DEPEND="*:2.6"
SUPPORT_PYTHON_ABIS=1
inherit distutils
@@ -17,11 +17,13 @@ SRC_URI="http://www.radicale.org/src/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~x86 ~amd64"
-IUSE="ssl"
+IUSE="ldap fastcgi ssl"
# the '>=' goes ok, as radicale supports _all_ other python version
# this includes all 3.* versions
-DEPEND="ssl? ( >=dev-lang/python-2.6.6[ssl] )"
+DEPEND="ssl? ( >=dev-lang/python-2.6.6[ssl] )
+ ldap? ( dev-python/ldap )
+ fastcgi? ( dev-python/flup )"
RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
@@ -34,15 +36,19 @@ src_install() {
# config file
insinto /etc/${PN}
- doins config || die
+ doins config "${FILESDIR}"/logging || die
- # fcgi file
+ # fcgi & wsgi file
insinto /usr/share/${PN}
- doins radicale.fcgi
+ doins "${FILESDIR}/radicale.wsgi"
+ use fastcgi && doins "${FILESDIR}/radicale.fcgi"
}
pkg_postinst() {
einfo "Radicale now supports WSGI."
- einfo "The fcgi-script to be used by the server has been put into
+ einfo "A sample wsgi-script has been put into
${ROOT}usr/share/${PN}."
+ if use fastcgi; then
+ einfo "There you will also find an example fcgi-script."
+ fi
}