summaryrefslogtreecommitdiff
path: root/app-office/radicale/radicale-9999.ebuild
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2011-03-11 23:27:39 +0100
committerRené 'Necoro' Neumann <necoro@necoro.net>2011-03-11 23:27:39 +0100
commit6cd79c9cb84bf953da65a1bf28820d550e9cdee3 (patch)
treeb1448e2b396d93cf1e609cd061be2dc0d5a91287 /app-office/radicale/radicale-9999.ebuild
parentc5c9d02035f1ef6858353e75e1f61eac0c9472d1 (diff)
downloadoverlay-6cd79c9cb84bf953da65a1bf28820d550e9cdee3.tar.gz
overlay-6cd79c9cb84bf953da65a1bf28820d550e9cdee3.tar.bz2
overlay-6cd79c9cb84bf953da65a1bf28820d550e9cdee3.zip
Radicale git
Diffstat (limited to 'app-office/radicale/radicale-9999.ebuild')
-rw-r--r--app-office/radicale/radicale-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-office/radicale/radicale-9999.ebuild b/app-office/radicale/radicale-9999.ebuild
new file mode 100644
index 0000000..838738b
--- /dev/null
+++ b/app-office/radicale/radicale-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+PYTHON_DEPEND="*:2.5"
+SUPPORT_PYTHON_ABIS=1
+
+EGIT_REPO_URI="git://gitorious.org/~necoro/radicale/radicale-nec.git"
+
+inherit distutils git
+
+DESCRIPTION="A simple CalDAV calendar server"
+HOMEPAGE="http://www.radicale.org/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+S=${WORKDIR}/radicale-nec
+
+src_install() {
+ distutils_src_install
+
+ # init file
+ newinitd "${FILESDIR}"/radicale.init.d radicale || die
+
+ # config file
+ insinto /etc/${PN}
+ doins config || die
+}
+
+pkg_postinst() {
+ elog "If you want to use SSL with ${PN}, please check that you have"
+ elog "installed >=dev-lang/python-2.6[ssl]."
+}