summaryrefslogtreecommitdiff
path: root/dev-lang/polyml/polyml-5.4.ebuild
diff options
context:
space:
mode:
authorRené Neumann <rene.neumann@in.tum.de>2011-07-27 11:16:35 +0200
committerRené Neumann <rene.neumann@in.tum.de>2011-07-27 11:16:35 +0200
commitea3a8574128fde8ca35ebe312e28f8a56d77b583 (patch)
tree6609f72fb2885fa8876c923a0467558f9aa44ded /dev-lang/polyml/polyml-5.4.ebuild
parent69e7ed4b07754ae656094afa26d4c4ab66c85ab8 (diff)
downloadoverlay-ea3a8574128fde8ca35ebe312e28f8a56d77b583.tar.gz
overlay-ea3a8574128fde8ca35ebe312e28f8a56d77b583.tar.bz2
overlay-ea3a8574128fde8ca35ebe312e28f8a56d77b583.zip
polyml
Diffstat (limited to 'dev-lang/polyml/polyml-5.4.ebuild')
-rw-r--r--dev-lang/polyml/polyml-5.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-lang/polyml/polyml-5.4.ebuild b/dev-lang/polyml/polyml-5.4.ebuild
new file mode 100644
index 0000000..b436597
--- /dev/null
+++ b/dev-lang/polyml/polyml-5.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/polyml/polyml-5.2.1.ebuild,v 1.3 2009/01/11 19:16:52 maekke Exp $
+
+EAPI=4
+
+MY_P=${PN}.${PV}
+
+DESCRIPTION="Poly/ML is a full implementation of Standard ML"
+HOMEPAGE="http://www.polyml.org"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gmp X"
+
+RDEPEND="X? ( x11-libs/openmotif )
+ gmp? ( dev-libs/gmp )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # Add the GNU-Header to the assembly file
+ # as given in http://www.gentoo.org/proj/en/hardened/gnu-stack.xml
+ # I hope it does no harm
+ cat >> ${S}/libpolyml/x86asm.asm << EOF
+#if defined(__linux__) && defined(__ELF__)
+.section .note.GNU-stack,"",%progbits
+#endif
+EOF
+}
+
+src_configure() {
+ econf $(use_with X x)\
+ $(use_with gmp)
+}