summaryrefslogtreecommitdiff
path: root/dev-tex
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.eu>2019-11-12 01:12:26 +0100
committerRené 'Necoro' Neumann <necoro@necoro.eu>2019-11-12 01:12:26 +0100
commitfee7d67889bf4c2fb713758d9f9e616dd1a57402 (patch)
tree43c7606172a313775c91f2c3794ec550b27481ea /dev-tex
parent23589740c529ef6e15f2c32358c8e95d6e4619c4 (diff)
downloadoverlay-fee7d67889bf4c2fb713758d9f9e616dd1a57402.tar.gz
overlay-fee7d67889bf4c2fb713758d9f9e616dd1a57402.tar.bz2
overlay-fee7d67889bf4c2fb713758d9f9e616dd1a57402.zip
Add newer versions with py3 support
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/dot2tex/Manifest1
-rw-r--r--dev-tex/dot2tex/dot2tex-2.11.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-tex/dot2tex/Manifest b/dev-tex/dot2tex/Manifest
new file mode 100644
index 0000000..3e2b883
--- /dev/null
+++ b/dev-tex/dot2tex/Manifest
@@ -0,0 +1 @@
+DIST dot2tex-2.11.3.tar.gz 664750 BLAKE2B 9c7effeca0d71810ce37e126df9e7df2b9df19be41393916c85e49df0dc116f42e58a2b29cce9e2bac700fa00859c63c1a4a8c41c70a9db96a5fc210960f463b SHA512 1595299811461b18cff490a8a56c0215f46989dd4a46fa087b455c717ed5d5f7a5782d04acaa3e4567b4e348bca866d5f24d21663012c4cd813445804ef6f714
diff --git a/dev-tex/dot2tex/dot2tex-2.11.3.ebuild b/dev-tex/dot2tex/dot2tex-2.11.3.ebuild
new file mode 100644
index 0000000..43787ab
--- /dev/null
+++ b/dev-tex/dot2tex/dot2tex-2.11.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Graphviz to LaTeX converter"
+HOMEPAGE="https://dot2tex.readthedocs.org/ https://github.com/kjellmf/dot2tex"
+SRC_URI="https://github.com/kjellmf/dot2tex/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="doc examples"
+
+DEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/pydot[${PYTHON_USEDEP}]
+ media-gfx/graphviz"
+DEPEND="${DEPEND}
+ doc? ( dev-python/sphinx )"
+
+python_compile_all() {
+ if use doc ; then
+ cd "${S}/docs"
+ emake html
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dohtml -r docs/_build/html/*
+ fi
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}