summaryrefslogtreecommitdiff
path: root/games-arcade/supertux/supertux-0.3.0.ebuild
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2008-04-16 18:25:51 +0200
committerRené 'Necoro' Neumann <necoro@necoro.net>2008-04-16 18:25:51 +0200
commitd9ec8413744faaba3543bff9773bdad9786260ab (patch)
treee3cb78524323873b8f164c43c1816e2bc3b86ff3 /games-arcade/supertux/supertux-0.3.0.ebuild
parentbf18b144c79fc2d322d627eccd267973b4ee3812 (diff)
downloadoverlay-d9ec8413744faaba3543bff9773bdad9786260ab.tar.gz
overlay-d9ec8413744faaba3543bff9773bdad9786260ab.tar.bz2
overlay-d9ec8413744faaba3543bff9773bdad9786260ab.zip
Added stuff from laptop
Diffstat (limited to 'games-arcade/supertux/supertux-0.3.0.ebuild')
-rwxr-xr-xgames-arcade/supertux/supertux-0.3.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-arcade/supertux/supertux-0.3.0.ebuild b/games-arcade/supertux/supertux-0.3.0.ebuild
new file mode 100755
index 0000000..dca82a9
--- /dev/null
+++ b/games-arcade/supertux/supertux-0.3.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/supertux/supertux-0.3.0.ebuild,v
+# 1.8 2006/12/23 01:19:37 chainsaw Exp $
+
+#GAMES_USE_SDL="nojoystick" #bug #100372
+inherit eutils games
+
+DESCRIPTION="A game similar to Super Mario Bros."
+HOMEPAGE="http://super-tux.sourceforge.net"
+SRC_URI=" http://download.berlios.de/supertux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND=" >=media-libs/libsdl-1.2.4
+ >=media-libs/sdl-image-1.2.2
+ sys-libs/zlib
+ dev-util/jam
+ >=dev-games/physfs-1.0.0
+ media-libs/libvorbis
+ media-libs/libogg
+ media-libs/openal"
+DEPEND="${RDEPEND}
+x11-libs/libXt"
+
+pkg_setup() {
+ games_pkg_setup
+}
+
+src_compile() {
+ egamesconf --disable-debug || die
+ jam || die "jam failed"
+}
+
+src_install() {
+ jam -sDESTDIR=${D} -sappdocdir=/usr/share/doc/${PF} \
+ -sapplicationsdir=/usr/share/applications \
+ -spixmapsdir=/usr/share/pixmaps \
+ install \
+ || die "jam install failed"
+
+ # Documentation
+ # gzip
+ gzip ${D}/usr/share/doc/${PF}/*
+
+ prepgamesdirs
+}