summaryrefslogtreecommitdiff
path: root/app-office/radicale/radicale-0.3-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/radicale/radicale-0.3-r3.ebuild')
-rw-r--r--app-office/radicale/radicale-0.3-r3.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/app-office/radicale/radicale-0.3-r3.ebuild b/app-office/radicale/radicale-0.3-r3.ebuild
index ad46e6e..3e2a99e 100644
--- a/app-office/radicale/radicale-0.3-r3.ebuild
+++ b/app-office/radicale/radicale-0.3-r3.ebuild
@@ -6,7 +6,7 @@ EAPI=2
PYTHON_DEPEND="*:2.5"
SUPPORT_PYTHON_ABIS=1
-inherit distutils
+inherit eutils distutils
MY_P="${PN/r/R}-${PV}"
@@ -21,6 +21,18 @@ IUSE=""
S=${WORKDIR}/${MY_P}
+src_prepare() {
+ distutils_src_prepare
+
+ epatch ${FILESDIR}/radicale-0.3-foreground.patch
+}
+
+src_install() {
+ distutils_src_install
+
+ newinitd ${FILESDIR}/radicale.init.d radicale
+}
+
pkg_postinst() {
elog "If you want to use SSL with ${PN}, please check that you have"
elog "installed >=dev-lang/python-2.6[ssl]."