summaryrefslogtreecommitdiff
path: root/dev-perl/X11-XCB
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/X11-XCB')
-rw-r--r--dev-perl/X11-XCB/Manifest1
-rw-r--r--dev-perl/X11-XCB/X11-XCB-0.09.ebuild35
-rw-r--r--dev-perl/X11-XCB/files/X11-XCB-0.09-dynamic-linking.patch70
-rw-r--r--dev-perl/X11-XCB/files/X11-XCB-0.09-fix-xcb-includes.patch15
4 files changed, 0 insertions, 121 deletions
diff --git a/dev-perl/X11-XCB/Manifest b/dev-perl/X11-XCB/Manifest
deleted file mode 100644
index 1fa575a..0000000
--- a/dev-perl/X11-XCB/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST X11-XCB-0.09.tar.gz 702693 SHA256 e365aeb84a1e2fddd05d6c59ee38548356a2db28fa0170b057ac5e661405201f SHA512 bdc36588606527a9c8c6cdd573f04b8cf42734b7cc7f78b5de459c48489a191896718372a3f41a982fa437d270d6d3fed2e59b39b32d8134bbd9bb9649dcdb00 WHIRLPOOL 162476faadb4d4019a5aad8bf32e5c1bcb2aaf4c7c542f63362024aa186814ae7d832abc4b32ef5d13c0e7d64ee81fb4aa0f5e009749324a456728a05a45bffe
diff --git a/dev-perl/X11-XCB/X11-XCB-0.09.ebuild b/dev-perl/X11-XCB/X11-XCB-0.09.ebuild
deleted file mode 100644
index 3ca45f1..0000000
--- a/dev-perl/X11-XCB/X11-XCB-0.09.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-MODULE_AUTHOR="MSTPLBG"
-
-inherit eutils perl-module
-
-DESCRIPTION="X11::XCB - perl bindings for libxcb"
-
-LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
-SLOT="0"
-
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="dev-perl/XS-Object-Magic
- dev-perl/extutils-depends
- dev-perl/extutils-pkgconfig
- virtual/perl-ExtUtils-ParseXS
- x11-libs/libxcb"
-
-RDEPEND="dev-perl/Mouse
- dev-perl/MouseX-NativeTraits
- dev-perl/Try-Tiny
- virtual/perl-XSLoader
- x11-libs/libxcb"
-
-src_prepare() {
- epatch "${FILESDIR}/X11-XCB-0.09-dynamic-linking.patch"
- epatch "${FILESDIR}/X11-XCB-0.09-fix-xcb-includes.patch"
-
- perl-module_src_prepare
-}
diff --git a/dev-perl/X11-XCB/files/X11-XCB-0.09-dynamic-linking.patch b/dev-perl/X11-XCB/files/X11-XCB-0.09-dynamic-linking.patch
deleted file mode 100644
index 817d3ee..0000000
--- a/dev-perl/X11-XCB/files/X11-XCB-0.09-dynamic-linking.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-diff --git a/Makefile.PL b/Makefile.PL
-index 6dff406..67f54c4 100644
---- a/Makefile.PL
-+++ b/Makefile.PL
-@@ -63,61 +63,11 @@ use_ppport;
- cc_warnings if $ENV{X11_XCB_CC_WARNINGS};
-
- require ExtUtils::Depends;
-+require ExtUtils::PkgConfig;
-
--cc_include_paths 'bundled-libs/libxcb-1.8.1/src';
--
--# We link the bundled xcb libraries statically so we don’t have to install them
--# on the system (that might not be possible due to missing permissions).
--makemaker_args->{MYEXTLIB} = join(' ', qw(
-- bundled-libs/libxcb-1.8.1/src/.libs/libxcb.a
-- bundled-libs/libxcb-1.8.1/src/.libs/libxcb-xinerama.a
--));
--makemaker_args->{LDLOADLIBS} = '-lXau -lXdmcp';
--
--{
-- package MY;
-- sub postamble {
-- <<'__EOF__';
--$(MYEXTLIB):
-- echo "xcbincludedir=$$(pwd)/bundled-libs/xcb-proto-1.7.1/src" > bundled-libs/xcb-proto.pc
-- echo "pythondir=$$(pwd)/bundled-libs/xcb-proto-1.7.1/" >> bundled-libs/xcb-proto.pc
-- echo "" >> bundled-libs/xcb-proto.pc
-- echo "Name: XCB Proto" >> bundled-libs/xcb-proto.pc
-- echo "Description: X protocol descriptions for XCB" >> bundled-libs/xcb-proto.pc
-- echo "Version: 1.7.1" >> bundled-libs/xcb-proto.pc
-- cd bundled-libs/libxcb-1.8.1/ && PKG_CONFIG_PATH=$$(pwd)/.. ./configure --with-pic --disable-shared \
-- --disable-composite \
-- --disable-damage \
-- --disable-dpms \
-- --disable-dri2 \
-- --disable-glx \
-- --disable-randr \
-- --disable-record \
-- --disable-render \
-- --disable-resource \
-- --disable-screensaver \
-- --disable-shape \
-- --disable-shm \
-- --disable-sync \
-- --disable-xevie \
-- --disable-xfixes \
-- --disable-xfree86-dri \
-- --disable-xinput \
-- --disable-xkb \
-- --disable-xprint \
-- --disable-selinux \
-- --disable-xtest \
-- --disable-xv \
-- --disable-xvmc && $(MAKE)
--
--__EOF__
-- }
--}
--
--if ($Module::Install::AUTHOR or $ENV{X11_XCB_GENERATE}) {
-- require _GenerateMyXS;
-- _GenerateMyXS::generate();
--}
-+makemaker_args->{INC} = ExtUtils::PkgConfig->cflags_only_I('xcb');
-+makemaker_args->{CFLAGS} = ExtUtils::PkgConfig->cflags_only_other('xcb');
-+makemaker_args->{LIBS} = ExtUtils::PkgConfig->libs('xcb');
-
- WriteMakefile(
- ExtUtils::Depends
diff --git a/dev-perl/X11-XCB/files/X11-XCB-0.09-fix-xcb-includes.patch b/dev-perl/X11-XCB/files/X11-XCB-0.09-fix-xcb-includes.patch
deleted file mode 100644
index 9cfdd87..0000000
--- a/dev-perl/X11-XCB/files/X11-XCB-0.09-fix-xcb-includes.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/XCB.xs b/XCB.xs
-index 152a5aa..d3060df 100644
---- a/XCB.xs
-+++ b/XCB.xs
-@@ -1,8 +1,8 @@
- #include "EXTERN.h"
- #include "perl.h"
- #include "XSUB.h"
--#include <xcb.h>
--#include <xinerama.h>
-+#include <xcb/xcb.h>
-+#include <xcb/xinerama.h>
-
- #include "ppport.h"
-