summaryrefslogtreecommitdiff
path: root/dev-python/htmlgen
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/htmlgen')
-rw-r--r--dev-python/htmlgen/Manifest2
-rw-r--r--dev-python/htmlgen/htmlgen-2.2.2.ebuild57
2 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/htmlgen/Manifest b/dev-python/htmlgen/Manifest
deleted file mode 100644
index c9d8cd4..0000000
--- a/dev-python/htmlgen/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST HTMLgen.tgz 316415 RMD160 bb32b2822f7ce8e49eb42853aff330429df073de SHA1 a34b9c1f9cf5536a548c66522213ac9fee1b43cd SHA256 f3b39b4b07b5dd318780ad0e9b8b3c524a54138537697dd7966223f314d2177d
-EBUILD htmlgen-2.2.2.ebuild 1516 RMD160 be11b4994918a74d31b2ad0e8ac1d9de4a261c83 SHA1 02e9255b1f7dce57099d27ac4816173937f02ad2 SHA256 74676d11d3b94db70fb9f22f393cecee6d9bdffef2eeeca23358feb06859756a
diff --git a/dev-python/htmlgen/htmlgen-2.2.2.ebuild b/dev-python/htmlgen/htmlgen-2.2.2.ebuild
deleted file mode 100644
index b6d9879..0000000
--- a/dev-python/htmlgen/htmlgen-2.2.2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/htmlgen/htmlgen-2.2.2.ebuild,v 1.12 2006/07/12 15:39:25 agriffis Exp $
-
-inherit python
-
-MY_P="HTMLgen"
-DESCRIPTION="HTMLgen - Python modules for the generation of HTML documents"
-HOMEPAGE="http://starship.python.net/crew/friedrich/HTMLgen/html/main.html"
-SRC_URI="http://starship.python.net/crew/friedrich/${MY_P}.tgz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="ia64 ppc x86"
-IUSE="doc"
-
-DEPEND="virtual/python
- dev-python/imaging"
-
-S="${WORKDIR}/${MY_P}"
-
-src_compile() {
- # nothing to do
- :
-}
-
-src_install() {
- # doing this manually because their build scripts suck
- local files="HTMLgen.py HTMLcolors.py HTMLutil.py HTMLcalendar.py \
- barchart.py colorcube.py imgsize.py NavLinks.py Formtools.py \
- ImageH.py ImageFileH.py ImagePaletteH.py GifImagePluginH.py \
- JpegImagePluginH.py PngImagePluginH.py"
-
- touch __init__.py
-
- insinto $(python_get_sitedir)/htmlgen
- doins $files __init__.py || die "doins failed"
-
- if use doc; then
- # fix the image locations in the docs
- sed -i -e "s;../image/;image/;g" html/* || die "sed failed"
- dohtml html/*
- dohtml -r image
- fi
- dodoc README
-}
-
-pkg_postinst() {
- python_mod_optimize $(python_get_sitedir)/htmlgen
-
- ewarn "htmlgen now resides in its own subdirectory"
- ewarn "so you need to do \"from htmlgen import HTMLgen\" instead of \"import HTMLgen\""
-}
-
-pkg_postrm () {
- python_mod_cleanup $(python_get_sitedir)/htmlgen
-}