summaryrefslogtreecommitdiff
path: root/dev-util/itstool/itstool-2.0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/itstool/itstool-2.0.6.ebuild')
-rw-r--r--dev-util/itstool/itstool-2.0.6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/itstool/itstool-2.0.6.ebuild b/dev-util/itstool/itstool-2.0.6.ebuild
new file mode 100644
index 0000000..e811060
--- /dev/null
+++ b/dev-util/itstool/itstool-2.0.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_REQ_USE="xml"
+
+inherit python-single-r1
+
+DESCRIPTION="Translation tool for XML documents that uses gettext files and ITS rules"
+HOMEPAGE="http://itstool.org/"
+SRC_URI="http://files.itstool.org/itstool/${P}.tar.bz2"
+
+# files in /usr/share/itstool/its are HPND/as-is || GPL-3
+LICENSE="GPL-3+ || ( HPND GPL-3+ )"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~x86-linux"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+DOCS=( ChangeLog NEWS ) # AUTHORS, README are empty