summaryrefslogtreecommitdiff
path: root/games-simulation
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/openttd/Manifest5
-rw-r--r--games-simulation/openttd/files/libiconv.patch10
-rw-r--r--games-simulation/openttd/openttd-0.6.0.ebuild193
3 files changed, 208 insertions, 0 deletions
diff --git a/games-simulation/openttd/Manifest b/games-simulation/openttd/Manifest
new file mode 100644
index 0000000..3ba2c4d
--- /dev/null
+++ b/games-simulation/openttd/Manifest
@@ -0,0 +1,5 @@
+AUX libiconv.patch 338 RMD160 a59441b635c7958fb544a59828f31282ff149bac SHA1 4b0978baff6a99928430b5ba418e47e3d45c98f2 SHA256 43ebbd73f8f59a4c55f3a220616f4c87c4211f1e09836750616758fd6b502789
+DIST openttd-0.4.8-scenarios.tar.bz2 5000799 RMD160 a6c2fa9f81e4e4628adb9c3932dec46ab4789777 SHA1 88b3caff739fbf7bd4eb143ae97925556e813ce4 SHA256 61788035bd78a3c0e393d5992432c37e0b6036d19a960543f26d43a46e39e6ca
+DIST openttd-0.5.0-scenarios.tar.bz2 917117 RMD160 f6ea4a4004bb0c90de9283a92b14da4bd99bc33c SHA1 965fc34bbe9998741ea07531772c9673b33aab99 SHA256 c89e652aca1a9ad9f0f4936dd99cd8a9c96f4c53450990ff87d87483f8e74a31
+DIST openttd-0.6.0-source.tar.bz2 3688002 RMD160 9ba4d63d4613779ae57a96fa25d4bb897c558976 SHA1 94c55f80e3869decb5b613d78f3b889f7168b6e5 SHA256 39955ae5355299ac99f97093d01e66403516275dcac0f575bf1f3d0c67c17999
+EBUILD openttd-0.6.0.ebuild 5736 RMD160 43af7b40ab377eb43ef116fda2cdf75a5d38ae74 SHA1 570006faa710ecfbf27f24464f12218bce5a4965 SHA256 d4fe1cb067bd972bed6441fdd9bddc5bb615ad3091ca69c90ab03dfcaf3669e8
diff --git a/games-simulation/openttd/files/libiconv.patch b/games-simulation/openttd/files/libiconv.patch
new file mode 100644
index 0000000..2b9cb12
--- /dev/null
+++ b/games-simulation/openttd/files/libiconv.patch
@@ -0,0 +1,10 @@
+--- config.lib 2008-01-15 21:55:36.000000000 +0100
++++ config.lib_new 2008-01-16 16:55:39.000000000 +0100
+@@ -1134,7 +1134,6 @@
+
+ if [ "$with_iconv" != "0" ]; then
+ CFLAGS="$CFLAGS -DWITH_ICONV"
+- LIBS="$LIBS -liconv"
+ if [ "$with_iconv" != "2" ]; then
+ CFLAGS="$CFLAGS -I$with_iconv/include"
+ LIBS="$LIBS -L$with_iconv/lib"
diff --git a/games-simulation/openttd/openttd-0.6.0.ebuild b/games-simulation/openttd/openttd-0.6.0.ebuild
new file mode 100644
index 0000000..f76aa3b
--- /dev/null
+++ b/games-simulation/openttd/openttd-0.6.0.ebuild
@@ -0,0 +1,193 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-0.5.3.ebuild,v 1.3 2007/10/20 18:59:16 pylon Exp $
+
+inherit eutils games
+
+SCENARIOS_048="${PN}-0.4.8-scenarios.tar.bz2"
+SCENARIOS_050="${PN}-0.5.0-scenarios.tar.bz2"
+
+DESCRIPTION="OpenTTD is a clone of Transport Tycoon Deluxe"
+HOMEPAGE="http://www.openttd.com/"
+SB="mirror://sourceforge/openttd"
+SRC_URI="${SB}/${P}-source.tar.bz2
+ scenarios? ( ${SB}/${SCENARIOS_048}
+ ${SB}/${SCENARIOS_050} )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="alsa debug dedicated iconv png scenarios static timidity zlib"
+
+DEPEND="!dedicated? ( media-libs/libsdl
+ media-libs/fontconfig
+ )
+ iconv? ( virtual/libiconv )
+ png? ( media-libs/libpng )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}
+ !dedicated? (
+ timidity? ( media-sound/timidity++ )
+ !timidity? ( alsa? ( media-sound/alsa-utils ) )
+ )"
+
+pkg_setup() {
+ if ! use dedicated && ! built_with_use media-libs/libsdl X ; then
+ die "Please emerge media-libs/libsdl with USE=X"
+ fi
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack ${P}-source.tar.bz2
+ if use scenarios ; then
+ cd "${S}"/bin/scenario/
+ unpack ${SCENARIOS_048}
+ unpack ${SCENARIOS_050}
+ fi
+ cd "${S}"
+
+ epatch "${FILESDIR}/libiconv.patch"
+}
+
+src_compile() {
+ local myopts=""
+ use debug && myopts="${myopts} --debug"
+ use dedicated && myopts="${myopts} --enable-dedicated --without-sdl"
+ if ! use dedicated; then
+ myopts="${myopts} --with-sdl --with-freetype --with-fontconfig"
+ if ! use timidity; then
+ #use alsa && myopts="${myopts} --with-midi=/usr/bin/aplaymidi"
+ einfo "This version of openttd does not support setting the midi-player."
+ fi
+ fi
+ # configure is a hand-written sh-script, so econf will not work
+ ./configure --os=UNIX --shared-dir="${GAMES_DATADIR}"/${PN}/ \
+ $(use_enable static) \
+ $(use_with iconv) \
+ $(use_with png) \
+ $(use_with zlib) \
+ ${myopts} \
+ || die "configure failed"
+
+ emake \
+ MANUAL_CONFIG=1 \
+ INSTALL=1 \
+ USE_HOMEDIR=1 \
+ DEST_DIR="${D}" \
+ PERSONAL_DIR=.openttd \
+ PREFIX="${GAMES_PREFIX}" \
+ INSTALL_DATA_DIR="${GAMES_DATADIR}"/${PN}/ \
+ || die "emake failed"
+
+# DATA_DIR="${GAMES_DATADIR}"/${PN} \
+# CUSTOM_LANG_DIR="${GAMES_DATADIR}"/${PN}/lang \
+
+}
+
+src_install() {
+ dogamesbin bin/openttd || die "dogamesbin failed"
+
+ insinto "${GAMES_DATADIR}"/${PN}/data
+ doins bin/data/* || die "doins failed (data)"
+
+ insinto "${GAMES_DATADIR}"/${PN}/lang
+ doins bin/lang/*.lng || die "doins failed (lang)"
+
+ if use scenarios ; then
+ insinto "${GAMES_DATADIR}"/${PN}/scenario
+ doins bin/scenario/*.scn || die "doins failed (scenario)"
+ doins bin/scenario/*/*.scn || die "doins failed (scenario)"
+ fi
+
+ insinto "${GAMES_DATADIR}"/${PN}/scripts
+ doins bin/scripts/*.example || die "doins failed (scripts)"
+
+ for i in {16,32,48,64,128}; do
+ insinto /usr/share/icons/hicolor/${i}x${i}/apps
+ newins media/openttd.${i}.png openttd.png
+ done
+
+ if ! use dedicated ; then
+ if use timidity || use alsa ; then
+ make_desktop_entry "openttd -m extmidi" "OpenTTD" openttd
+ else
+ make_desktop_entry openttd "OpenTTD" openttd
+ fi
+ else
+ newinitd "${FILESDIR}"/openttd.initd openttd
+ fi
+
+ dodoc readme.txt known-bugs.txt changelog.txt docs/Manual.txt \
+ docs/multiplayer.txt
+ dohtml -a html,gif,png,svg docs/*
+ newdoc scripts/readme.txt readme_scripts.txt
+ doman docs/openttd.6
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ echo
+ einfo "In order to play, you must copy the following 6 files from "
+ einfo "a version of TTD to ${GAMES_DATADIR}/${PN}/data/."
+ echo
+ einfo "From the WINDOWS version you need: "
+ einfo " sample.cat trg1r.grf trgcr.grf trghr.grf trgir.grf trgtr.grf"
+ einfo "OR from the DOS version you need: "
+ einfo " SAMPLE.CAT TRG1.GRF TRGC.GRF TRGH.GRF TRGI.GRF TRGT.GRF"
+ echo
+ einfo "File names are case sensitive so make sure they are "
+ einfo "correct for whichever version you have."
+ echo
+
+ if ! use scenarios ; then
+ einfo "Scenarios are now included in a seperate package. To "
+ einfo "install them as well please remerge with the "
+ einfo "\"scenarios\" USE flag."
+ echo
+ else
+ einfo "Scenarios are installed to"
+ einfo "${GAMES_DATADIR}/${PN}/scenario,"
+ einfo "you will have to symlink them to ~/.openttd/scenario in order"
+ einfo "to use them."
+ einfo "Example:"
+ einfo " mkdir -p ~/.openttd/scenario"
+ einfo " ln -s ${GAMES_DATADIR}/${PN}/scenario/* ~/.openttd/scenario/"
+ echo
+ fi
+
+ if use dedicated ; then
+ einfo "You have chosen the dedicated USE flag which builds a "
+ einfo "version of OpenTTD to be used as a game server which "
+ einfo "does not require SDL. You will not be able to play the "
+ einfo "game, but if you don't pass this flag you can still use "
+ einfo "it as a server in the same way, but SDL will be required."
+ echo
+ ewarn "Warning: The init script will kill all running openttd"
+ ewarn "processes when run, including any running client sessions!"
+ echo
+ else
+ if use timidity || use alsa ; then
+ einfo "If you want music, you must copy the gm/ directory to"
+ einfo "${GAMES_DATADIR}/${PN}/"
+ einfo "You can enable MIDI by running:"
+ einfo " openttd -m extmidi"
+ echo
+ if use timidity ; then
+ einfo "You also need soundfonts for timidity, if you don't"
+ einfo "know what that is, do:"
+ echo
+ einfo "emerge media-sound/timidity-eawpatches"
+ else
+ einfo "You have emerged with 'aplaymidi' for playing MIDI."
+ einfo "You have to set the environment variable ALSA_OUTPUT_PORTS."
+ einfo "Available ports can be listed by using 'aplaymidi -l'."
+ fi
+ else
+ einfo "timidity and/or alsa not in USE so music will not be played during the game."
+ fi
+ echo
+ fi
+}