summaryrefslogtreecommitdiff
path: root/net-libs/webkit-gtk/webkit-gtk-2.4.11-r201.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/webkit-gtk/webkit-gtk-2.4.11-r201.ebuild')
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.4.11-r201.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.4.11-r201.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.4.11-r201.ebuild
index 007ea47..af8aad9 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.4.11-r201.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.4.11-r201.ebuild
@@ -172,6 +172,12 @@ src_configure() {
# Respect CC, otherwise fails on prefix #395875
tc-export CC
+ # revert icu behavior
+ append-cxxflags -DUPRV_BLOCK_MACRO_BEGIN=\"\" -DUPRV_BLOCK_MACRO_END=\"\"
+
+ # disable warnings
+ append-cxxflags -w
+
# Arches without JIT support also need this to really disable it in all places
use jit || append-cppflags -DENABLE_JIT=0 -DENABLE_YARR_JIT=0 -DENABLE_ASSEMBLER=0