summaryrefslogtreecommitdiff
path: root/net-print/hplip/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-print/hplip/files')
-rw-r--r--net-print/hplip/files/70-hpmud.rules19
-rw-r--r--net-print/hplip/files/hplip-2.8.6b-add-sane-lib.patch15
2 files changed, 34 insertions, 0 deletions
diff --git a/net-print/hplip/files/70-hpmud.rules b/net-print/hplip/files/70-hpmud.rules
new file mode 100644
index 0000000..1e6ab66
--- /dev/null
+++ b/net-print/hplip/files/70-hpmud.rules
@@ -0,0 +1,19 @@
+# Udev rules file for HP printer products.
+
+ACTION!="add", GOTO="hpmud_rules_end"
+
+SUBSYSTEM!="usb|usb_device", GOTO="hpmud_rules_end"
+SUBSYSTEM=="usb", ENV{DEVTYPE}!="usb_device" ,GOTO="hpmud_rules_end"
+
+# Check for AiO products (0x03f0xx11).
+ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="??11", GROUP="lp"
+# Check for Photosmart products (0x03f0xx02).
+ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="??02", GROUP="lp"
+# Check for Business Inkjet products (0x03f0xx12).
+ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="??12", GROUP="lp"
+# Check for Deskjet products (0x03f0xx04).
+ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="??04", GROUP="lp"
+# Check for LaserJet products (0x03f0xx17).
+ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="??17", GROUP="lp"
+
+LABEL="hpmud_rules_end"
diff --git a/net-print/hplip/files/hplip-2.8.6b-add-sane-lib.patch b/net-print/hplip/files/hplip-2.8.6b-add-sane-lib.patch
new file mode 100644
index 0000000..ac543bd
--- /dev/null
+++ b/net-print/hplip/files/hplip-2.8.6b-add-sane-lib.patch
@@ -0,0 +1,15 @@
+=== modified file 'Makefile.am'
+--- Makefile.am 2008-11-10 17:43:43 +0000
++++ Makefile.am 2008-11-10 17:44:10 +0000
+@@ -198,8 +198,8 @@
+ # scanext
+ scanextdir = $(pyexecdir)
+ scanext_LTLIBRARIES = scanext.la
+-#scanext_la_LDFLAGS = -module -avoid-version -lsane
+-scanext_la_LDFLAGS = -module -avoid-version
++scanext_la_LDFLAGS = -module -avoid-version -lsane
++#scanext_la_LDFLAGS = -module -avoid-version
+ scanext_la_SOURCES = scan/scanext/scanext.c
+ scanext_la_CFLAGS = -I$(PYTHONINCLUDEDIR)
+ endif
+