summaryrefslogtreecommitdiff
path: root/net-www/mozplugger/mozplugger-1.10.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/mozplugger/mozplugger-1.10.2.ebuild')
-rw-r--r--net-www/mozplugger/mozplugger-1.10.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-www/mozplugger/mozplugger-1.10.2.ebuild b/net-www/mozplugger/mozplugger-1.10.2.ebuild
new file mode 100644
index 0000000..6d1c195
--- /dev/null
+++ b/net-www/mozplugger/mozplugger-1.10.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozplugger/mozplugger-1.7.3-r1.ebuild,v 1.1 2006/07/06 21:20:16 chutzpah Exp $
+
+inherit nsplugins
+
+DESCRIPTION="Streaming media plugin for Mozilla, based on netscape-plugger"
+SRC_URI="http://mozplugger.mozdev.org/files/${P}.tar.gz"
+HOMEPAGE="http://mozplugger.mozdev.org/"
+
+KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~alpha"
+LICENSE="GPL-2"
+
+SLOT="0"
+IUSE="firefox"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ !sparc? (
+ firefox? ( www-client/mozilla-firefox )
+ !firefox? ( www-client/seamonkey )
+ )
+ sparc? ( www-client/mozilla-firefox )"
+
+src_compile()
+{
+ cd ${S}
+ emake linux || die
+}
+
+src_install()
+{
+ cd ${S}
+ emake root=${D} install
+ src_mv_plugins /usr/lib/mozilla/plugins
+
+ dodoc ChangeLog COPYING README
+}