summaryrefslogtreecommitdiff
path: root/www-servers/hiawatha/files/hiawatha-9.0-no-bundled-polarssl.patch
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/hiawatha/files/hiawatha-9.0-no-bundled-polarssl.patch')
-rw-r--r--www-servers/hiawatha/files/hiawatha-9.0-no-bundled-polarssl.patch38
1 files changed, 0 insertions, 38 deletions
diff --git a/www-servers/hiawatha/files/hiawatha-9.0-no-bundled-polarssl.patch b/www-servers/hiawatha/files/hiawatha-9.0-no-bundled-polarssl.patch
deleted file mode 100644
index 2f32001..0000000
--- a/www-servers/hiawatha/files/hiawatha-9.0-no-bundled-polarssl.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-Hiawatha bundles PolarSSL. This is bad. Use the system-wide one.
-
-Upstream is not going to remove the bundling (it even uses .c files
-for certain operation when SSL is not enabled), so we need to keep this
-patch around.
-
-From: René Neumann <gentoo@necoro.eu>
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 1f4a312..0d8c6ca 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -92,15 +92,11 @@ include(CPack)
-
- # PolarSSL
- if(ENABLE_SSL)
-- option(USE_SHARED_POLARSSL_LIBRARY "Build PolarSSL as a shared library." ON)
-- set(CMAKE_INSTALL_NAME_DIR ${CMAKE_INSTALL_FULL_LIBDIR}/hiawatha)
-- set(LIB_INSTALL_DIR ${CMAKE_INSTALL_LIBDIR}/hiawatha)
-- add_subdirectory(polarssl)
-- set(POLARSSL_LIBRARY "polarssl")
-+ find_library(POLARSSL_LIBRARY polarssl)
- endif()
-
- # Hiawatha
--include_directories(${CMAKE_CURRENT_BINARY_DIR} polarssl/include)
-+include_directories(${CMAKE_CURRENT_BINARY_DIR})
- if(ENABLE_XSLT)
- include_directories(${LIBXML2_INCLUDE_DIR} ${LIBXSLT_INCLUDE_DIR})
- endif()
-@@ -124,7 +120,6 @@ target_link_libraries(wigwam ${CRYPT_LIBRARY})
- target_link_libraries(hiawatha ${CRYPT_LIBRARY} pthread ${Z_LIBRARY})
- if(ENABLE_SSL)
- target_link_libraries(hiawatha ${POLARSSL_LIBRARY})
-- set_target_properties(hiawatha PROPERTIES INSTALL_RPATH ${CMAKE_INSTALL_FULL_LIBDIR}/hiawatha)
- endif()
- if(ENABLE_XSLT)
- target_link_libraries(hiawatha ${LIBXML2_LIBRARIES} ${LIBXSLT_LIBRARIES})