summaryrefslogtreecommitdiff
path: root/www-servers/hiawatha/hiawatha-9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/hiawatha/hiawatha-9.0.ebuild')
-rw-r--r--www-servers/hiawatha/hiawatha-9.0.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/www-servers/hiawatha/hiawatha-9.0.ebuild b/www-servers/hiawatha/hiawatha-9.0.ebuild
index 414c07a..937851e 100644
--- a/www-servers/hiawatha/hiawatha-9.0.ebuild
+++ b/www-servers/hiawatha/hiawatha-9.0.ebuild
@@ -17,7 +17,8 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE="debug +cache chroot ipv6 monitor +rewrite rproxy ssl tomahawk xsl"
-DEPEND="ssl? ( >=net-libs/polarssl-1.2 )
+DEPEND="sys-libs/zlib
+ ssl? ( >=net-libs/polarssl-1.2 )
xsl? ( dev-libs/libxslt
dev-libs/libxml2 )"
@@ -27,9 +28,6 @@ PDEPEND="monitor? ( www-apps/hiawatha-monitor )"
PATCHES=("${FILESDIR}"/${P}-no-bundled-polarssl.patch)
src_configure() {
- if use debug; then
- CMAKE_BUILD_TYPE="RelWithDebInfo"
- fi
if use kernel_linux; then
local myargs=" -DENABLE_LOADCHECK=ON "
fi
@@ -59,5 +57,5 @@ src_install() {
newinitd "${FILESDIR}"/hiawatha.initd hiawatha
- keepdir /var/l{ib,og}/hiawatha
+ keepdir /var/{lib,log}/hiawatha
}