summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2009-08-14 23:09:00 +0200
committerRené 'Necoro' Neumann <necoro@necoro.net>2009-08-14 23:09:00 +0200
commit18edc07bf7735c0d72d1b9e69c1e566ebfa1c0c3 (patch)
treefa8f1c2777033f423732688dea0f7f1729edce8a /setup.py
parent9ff6fcfd4f0930c77ad3eb8b52d7328b86526cc4 (diff)
downloadportato-18edc07bf7735c0d72d1b9e69c1e566ebfa1c0c3.tar.gz
portato-18edc07bf7735c0d72d1b9e69c1e566ebfa1c0c3.tar.bz2
portato-18edc07bf7735c0d72d1b9e69c1e566ebfa1c0c3.zip
Correct setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py19
1 files changed, 17 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index f69d373..792e8e6 100644
--- a/setup.py
+++ b/setup.py
@@ -13,6 +13,8 @@
import os
from distutils.core import setup
+from distutils.extension import Extension
+from Cython.Distutils import build_ext
from portato.constants import VERSION, ICON_DIR, PLUGIN_DIR, TEMPLATE_DIR, APP
@@ -22,12 +24,24 @@ def plugin_list (*args):
"""Creates a list of correct plugin pathes out of the arguments."""
return [("plugins/%s.py" % x) for x in args]
-packages = ["portato", "portato.db", "portato.gui", "portato.gui.windows", "portato.plugins", "portato.backend", "portato.backend.portage"]
+packages = [
+ "portato",
+ "portato.db",
+ "portato.eix",
+ "portato.gui", "portato.gui.windows",
+ "portato.plugins",
+ "portato.backend", "portato.backend.portage"
+ ]
+
data_files = [
(TEMPLATE_DIR, [os.path.join("portato/gui/templates",x) for x in os.listdir("portato/gui/templates") if x.endswith(".ui")]),
(ICON_DIR, ["icons/portato-icon.png"]),
(PLUGIN_DIR, plugin_list("gpytage", "notify", "etc_proposals", "reload_portage", "package_details"))]
+ext_modules = [
+ Extension("portato.eix.parser", ["portato/eix/parser.pyx"])
+ ]
+
# do the distutils setup
setup(name=APP,
version = VERSION,
@@ -40,5 +54,6 @@ setup(name=APP,
author_email = "necoro@necoro.net",
packages = packages,
data_files = data_files,
- cmdclass={'build_manpage': build_manpage}
+ cmdclass={'build_manpage': build_manpage, 'build_ext' : build_ext},
+ ext_modules = ext_modules
)