summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2009-08-15 04:31:45 +0200
committerRené 'Necoro' Neumann <necoro@necoro.net>2009-08-15 04:31:45 +0200
commit310f605630dcdd63fe234409fa41d92816aa49c5 (patch)
treeb8a378e5ad2b385b373d2788a5951f4a70b4b9ed /setup.py
parent4feddaea01a755bcabc331a7a20836bc319f8b3e (diff)
downloadportato-310f605630dcdd63fe234409fa41d92816aa49c5.tar.gz
portato-310f605630dcdd63fe234409fa41d92816aa49c5.tar.bz2
portato-310f605630dcdd63fe234409fa41d92816aa49c5.zip
Add module to setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 4 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 01107f1..8628cbb 100644
--- a/setup.py
+++ b/setup.py
@@ -15,6 +15,8 @@ import os
import sys
from distutils.core import setup
+from distutils.extension import Extension
+from Cython.Distutils import build_ext
from portato.constants import VERSION, ICON_DIR, PLUGIN_DIR, TEMPLATE_DIR, APP
@@ -38,17 +40,12 @@ data_files = [
(PLUGIN_DIR, plugin_list("gpytage", "notify", "etc_proposals", "reload_portage", "package_details"))]
# extension stuff
-ext_modules = []
-cmdclass={'build_manpage': build_manpage}
+ext_modules = [Extension("portato.mq", ["portato/mq.pyx"])]
if "--disable-eix" in sys.argv:
sys.argv.remove("--disable-eix")
else:
- from Cython.Distutils import build_ext
- from distutils.extension import Extension
-
ext_modules.append(Extension("portato.eix.parser", ["portato/eix/parser.pyx"]))
- cmdclass['build_ext'] = build_ext
packages.append("portato.eix")
if "--enable-eix" in sys.argv:
@@ -67,5 +64,5 @@ setup(name=APP,
packages = packages,
data_files = data_files,
ext_modules = ext_modules,
- cmdclass = cmdclass
+ cmdclass={'build_manpage': build_manpage, 'build_ext' : build_ext}
)